[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unable to cd "/home/directory_name"

"budi wibowo" <bewei@stttelkom.ac.id> writes: 

> there's no problem wirh the permission because i have tried to add new
> user and then login with this newe account but it didn't work and
> the message appear but if i change uid of the new user with 0 i can
> login normally?  so.. should i reinstall my slink :(

     Do you mean that you checked the permissions, or that they must
be OK because you have tried to add a new user?    

     Did you check that /home/my_home_dir actually exists?

     Did you use a program to add the new user, or did you do it by
hand?  It is easy to get things messed up if you try to edit the
passwd and group files manually.  

There are two programs in slink to add a user - /usr/sbin/adduser and
/usr/sbin/useradd.  I don't know which is preferred in this
circumstance - perhaps someone more knowledgable will post the answer.
Are you using shadow passwords?

     I suggest you remove the new user with /usr/sbin/userdel, and
then re-add her using adduser or useradd.

     If you change the uid of the new user to 0, she can certainly
login, but she will have full root permissions - not very desirable.

     No, this doesn't mean you need to re-install slink.  The problem
can probably be resolved without re-installing anything.  The worst
case is that, if one package is determined to be corrupt, is that
that package must be reinstalled.


  |_)  _  |_       Robert D. Hilliard    <hilliard@flinet.com>
  |_) (_) |_)      Palm City, FL  USA    PGP Key ID: A8E40EB9

Reply to: