[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Re: qpopper: What does -ERR maillock: /var/spool/pop/username.pop mean



On Wed, Apr 21, 1999 at 04:58:18PM +0200, Nils Rennebarth wrote:
> I receive these messages in my syslog when debugging is turned on, and the
> user don't get their mail with pop-3, with the same error message.
> Telnetting to pop-3 port gives the same message and the session is ended
> after the USER and PASS commands.
> 
> I just newly installed qpopper on this machine. What could be wrong?
Hate to follow up on my own mails, but the above is solved:

I carelessly used tar in /var/spool/mail and got it's permissions changed
to rwxr-xr-x bin  mail instead of
   rwxrwxr-t root mail

ipopd still worked with the former settings which suggests it is running as
root and not dropping privileges. TssTss.

I found this using strace. Really great debugging tool.

qpopper's error message is misleading however, to say the least.

Nils

--
Plug-and-Play is really nice, unfortunately it only works 50% of the time.
To be specific the "Plug" almost always works.            --unknown source

Attachment: pgpIKASOfCi7V.pgp
Description: PGP signature


Reply to: