[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help connecting with earthlink

On Wed, 17 Mar 1999, Obi wrote:

> hello,
> I'm trying to setup my linux box to connect to earthlink, but with no luck.
> I've done that quite a few times with different ISPs, but this time I cannot
> set it up. 
> It works fine under windows98, but under linux no. This is the important part
> of the log:
> Mar 17 15:08:08 harp pppd[1139]: Using interface ppp0
> Mar 17 15:08:08 harp pppd[1139]: Connect: ppp0 <--> /dev/modem
> Mar 17 15:08:39 harp pppd[1139]: LCP: timeout sending Config-Requests
> Mar 17 15:08:39 harp pppd[1139]: Connection terminated.
> Mar 17 15:08:39 harp pppd[1139]: Hangup (SIGHUP)
> Should I set some CHAP/PAP things? Can you help?
> thanks
> graziano

I'm a "happy" Earthlink customer and when I set up my connection with them
I found that the prompt strings that they use are a little different from
the default, etc. I'm not at home now so I can't remember exactly what
they are. Also I'm using diald, but this should make no difference. How I
solved the problem was by using minicom to manually dial the modem and
then look at the prompt strings that Earthlink sends out. If I recall
correctly the 'login' and 'user' prompt strings are a little different
than the default. Once I changed these in the diald connect file (the
'expect' script) it worked great.
Hope this helps...

Reply to: