[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: More problems becoming a 'normal' user

"Rich Harran." wrote:
> I emailed a problem on the list yesterday, about getting to use X as a
> normal user.  The problem was the permissions of /dev/null, which I
> changed to:
>         crw-rw-rw-   1 root  root
> and everything worked.  However, when I restarted today, I had the same
> problem, and found that the permissions had changed back.  I'm using X
> now, as I've changed them again, but how do I stop them changing back when
> I restart?  ... Ok, I restarted again, and this time the permissions
> didn't change back, so I guess that's solved (bit wierd though!).
> Also, I want to be able to read-write automatically mounted dos drives as
> a normal user in group 'dos' (I read this was the right way to approach
> it in this list a while ago). I created the group, and added user 'rich'
> to it, but I can't change the group of the directory /mnt (my dos drive),
> to 'dos'.
> The drive is mounted with the line:
>         /dev/hda1      /mnt    vfat     defaults     0  0
> To what should I change this?  I've tried changing the options column to
>         defaults,gid=dos
> but then the drive refuses to mount (BTW how do I view the startup
> messages after they've whizzed off the top of the screen?).
> Sorry I crammed so many silly questions into one posting.
> Thanks in advance

	Something like the line below should work.  Make sure your user
is a member of the 'dos' group.  You should be able to type
'groups' and 'dos' will be one of the listed groups.
	Note the '35' below; thats the number (gid) of my 'dos' group. 
You'll need to replace it with the number assigned to your 'dos'
group.  Look in /etc/group for the number (while in this file,
double-check that the user is really in the 'dos' group).

	/dev/hda1   /dos   vfat   defaults,umask=002,uid=0,gid=35   0   0

Ed C.

Reply to: