[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED (sort of): Re: /etc/ppp/ip-up not being run

	Subject: SOLVED (sort of): Re: /etc/ppp/ip-up not being run
	Date: Wed, Nov 04, 1998 at 03:49:30PM -0500

In reply to:Noah L. Meyerhans

Quoting Noah L. Meyerhans(frodo@ccs.neu.edu):
> Doh!  I feel pretty dumb now.  The scripts ARE being run.  The problem
> does, however, seem to have something to do with the way in which they're
> being run.  One of the scripts contains an ftp command, which should
> (using a macro in /root/.netrc) connect to a remote site and upload a
> file.  I know the ftp macro works fine, because if I run my script by
> hand, things work just fine, and the file is uploaded automatically.
> However, when pppd tries to run the script, I find this in the output of
> the ftp process (which I redirect to a file):
> Name ( Login incorrect.
> But I'm NOT trying to log in as root!  The ftp macro specifies my username
> and password at the remote host.  As I said, all this works fine when I
> run the script by hand!

I had a simular problem once.  program ran from the command line but
not from a cron job.  Found the problem was that I had to set up the
PATH in the script as the path , while in crom, wasn't the same
as when I was on the command line.


> noah

It is easier to change the specification to fit the program than vice
Wayne T. Topa <wtopa@ix.netcom.com>

Reply to: