[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Netscape & libXpm.so.4



[Posted and mailed]

In article <Pine.GSO.3.96.980824145402.19052A-100000@eduserv1.rug.ac.be>,
	Kris.VanHulle@rug.ac.be (Kris Van Hulle) writes:
> I installed libc5 - still not working. Here some more information:
> 
> The error is:
> /usr/local/netscape/netscape: can't load library 'libXpm.so.4'
> 
> "ldd /usr/local/netscape/netscape" gives:

[cut]

>         libX11.so.6 => /usr/lib/libc5-compat/libX11.so.6 (0x40088000)
>         libc.so.5 => /lib/libc.so.5 (0x40129000)

So this is a libc5 version of netscape.  You need libc5 version of
libraries.

> 
> And "locate libXpm.so.4" gives me:
> 
> ===
> /usr/X11R6/lib/libXpm.so.4
> /usr/X11R6/lib/libXpm.so.4.10

These are libc6 versions.  libc5 versions would be in
/usr/lib/libc5-compat/ like libX11.so.6 shown above.

You need to install the xpm4.7 package (xpm4g is the libc6 package).
The same thing applies to libg++.  libg++27 is the libc5 pacakge you
need.  libg++272 is the libc6 version which you already have
installed.  In both cases and in general, the package description
(shown in dselect) specifies whether a library packages is for libc5
or for libc6.

> So I seem to have everything Netscape needs, but it still doesn't work.

Not quite everything.. ;)

Erv Walter

-- 
Graduate Student                                edwalter@iname.com
Department of Chemistry                       walter@chem.wisc.edu
Univ of Wisconsin-Madison               edwalter@students.wisc.edu
       <PGP Public Key: finger walter@fozzie.chem.wisc.edu>

Confirmation of the past is often the greatest surprise.
 -- tagline 1.00 by xopy


Reply to: