[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

printing not working

I'm trying to get printing working on a friend's new laptop.  He actually
had it working on his old laptop.  When we tried printing first up,
it didn't print, and we got the following error:

$ lpq
Printer: lp@genoa  'Generic dot-matrix printer entry'
 Queue: 1 printable job
 Server: pid 6836 active
 Unspooler: pid 6837 active
 Status: cannot open '/dev/lp1' - 'Device not configured', attempt 1,
sleeping 10 at 21:36:37
 Rank   Owner/ID                   Class Job  Files               Size
active  bill@genoa+523                 A  523 slidemac.tex       2625

I thought the problem was that we hadn't yet set up /etc/printcap
properly.  After copying across the appropriate files from the old laptop
(on which printing worked fine - and it also used Debian), I tried
printing again.  This time I couldn't even get a print job to queue:

$ lpr temp.txt
connection to 'localhost' failed - Connection refused
job 'cfA812genoa.ist.flinders.edu.au' transfer to lp@localhost failed

$ lpq
Host 'localhost' - cannot open connection to `lp@localhost' - Connection

I even tried running magicfilterconf again (we use magicfilter),
but the file generated had the same problem as just above.

Is there something wrong with /dev/lp1?  Or is something else wrong?

Any help gratefully accepted.



____\__/HE___\__/------APTAIN/   ________________________________
____\__/_____\__/--\__/______/  /__"To be is to do."__I. Kant___/
____\__/______\______/_______/  /__"To do is to be."__A. Sartre_/
                                /__"I am."____________God_______/
                                /__Jesus did.___________________/

Reply to: