[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation problems (adaptec 2940)

I am trying to install debian 2.0 on my machine, and run into 3
disk-related problems.  I also have os2 on the machine and that works, so
I don't believe the hardware is broken.

I have 2 ide drives for data files, and 3 scsi drives
connected to an adaptec 2940 controller.

I was able to install the base os using the fast rescue1440
floppy disk.  The install program could see all scsi drives
(sda,sdb,sdc as well as the cdrom)

I made a boot diskette and rebooted.  This went wrong during scsi
initialisation.  My first two scsi drives were recognised, but the kernel
never got past the third one.  I got an endless loops with error messages,
something went wrong during "SELTO".  I haven't got the exact wording as I
couldn't stop the scrolling.  I can try  to read it if anybody think they
can help.

I removed the third scsi drive and could then get the system to boot. Not
a good solution, but I figured I could look at that later.   I find this
strange, as the install program worked fine with that drive.

Now the worst problem began:
I ran dselect in order to install the "usual" stuff, emacs, X, gcc and so
on.  I selected a lot of packages and started the installing. Installation
seemed to work for a while with lots of cd and disk activity. 
Then it went bad, with lots of scsi timeouts.  Sometimes on
scsi id 0 (/, /var, and swap) sometimes on scsi id 1 (/usr and /home)
Timeouts were infrequent at first, then they occured more and more often. 
Disk activity ceased.  I could still type in other
tty's, but any command needing the scsi drives would freeze.

I have rebooted several times, and it is always the same.  One or more
scsi drives lock up after running dselect for a while.
I am stuck.  I cannot yet read manpages or compile a new kernel, because
installation haven't got that far.
Is the adaptec 2940 driver supposed to work fine, or is it some kind of
beta? I bought the adapter in 1994, it has bios version 1.1 if I remember
correctly. Are there any special hardware considerations?  Any special
kernel I could try?  

Last and least:
I currently have to boot linux using a diskette, this is slow. I have
tried adding the linux partition to the boot manager that comes with os2,
but it complains that the partition is "unformatted" when I try to boot
it.  Lilo complained a bit about the root partition being in an extended
partition.  Should I repartition for a primary partition, or is there
easier ways?  I don't yet have anything to loose as the other problems
prevent me from setting up a useful system.

Helge Hafting


Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: