[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot: unable to open initial console

On Mon, Aug 03, 1998 at 05:52:36PM +0200, Dirk Bonne wrote:
> Taren wrote:
> > 


> > 
> > Or the permissions aren't set right.  I've found that when copying files
> > from /dev, the permissions rarely stay the way they were originally
> They should with tar. e.g.:
>   tar cf - . | (cd somewhere; tar xvf -)
> Of course, you must set umask to 000 beforehand

Actually, I tried pretty much the same command as you suggest:

	tar -cf - $dir | (cd /mnt; tar -xpsf -)

This worked well for ordinary files and some special files, but any sockets
in /dev or /var were turned into pipes.  At least, the first mode bit
changed from an 's' to a 'p'.  I don't think the device numbers changed, but
the mode bit change was enough to scare me.  I used cpio in /dev and /var
and it seemed to preserve everything.

	But I still have my "Can't open initial console" problem.  Maybe all
the device files got moved fine as far as ls -l is concerned but not on a
more fundamental and functional level.

	Perhaps I should just cd /mnt/dev; rm * and then remake the device
files.  I've read about a command to make the devices.  Can't remember
where nor what the command was.  

	Anyone know where to go to get info on recreating the device files ?



Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: