[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Grabbing sockets with bind???

I have had a problem under debian linux..and I just can't figure out WHY
I am
a while back the "land" attack was posted on bugtraq...and just for
"Shits and giggles" I decided to see if I could make a version of it
using a shell script and the "netcat" program.
I did and it worked fine under RedHat 5.0 ...but under debian it gives
here is the meat of it it starts with
nc -n -z -w9 "$1" "$2" || {echo "error messga ehere" ;  exit0 ;}
that basically checks to make sur ethat the computer on the
reciving end is listening onthat prt and exists if it doesn't
work...that passes fine...
here is the "meat" of it:
nc -n -s "$1" -p "$2" "$1" "$2" -w 2
here it errors. when I send it after my own win95 machine (I said it was
only for
"shits and giggles" I don't see much point in crashing someone elses
when I can't sit here and actually SEE it crash )
anyway...today my win95 IP is (don't even try...its
behind a
VERY restrictive firewall) I get this error:
Can't grab with bind : Cannot assign requested IP
in fact I get that error anytime I try to use netcats very limited IP
spoofing capabilities
ok..yea..I know this isn't stff im "supposed to be doing"
but I am curious to know what is differnt about the debian
system from the  RedHat system that I wrote this on?
I even tried running it as root (and with nc suid root)....still no luck

I realize that this is a very good policy for normal systems but...
how do I turn it off on my singl euser system here just for some fun?
-=Signature has been removed because it made an unfair comparison
between NT 4 and Linux =-
replacement: (ok I admit...I am bored..its a slow day at work)
[sjc@debian ~]$fortune -o
Anything more than 3 shakes is for fun.

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: