[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

printer trouble

Hello everyone,

I recently got a problem with a printer filter used by lpr.  The filter
is used for a HP Deskjet 870 cxi, and used to work properly on this
machine, and still does on other machines:

The princap entry is:
gs filter for HP Deskjet 870 CXI|hp870ps|col1:\

The filter /etc/filters/filter870.ps looks like:

/usr/bin/gs     -sDEVICE=cdj550 \
                -q \
                -r300x300 \
                -sPAPERSIZE=a4 \
                -dNOPAUSE \
                -dSAFER \
                -sOutputFile=- \
                - | \
lpr -Php870raw

hp870raw is a remote printer.  The problem might be caused by the
fact that gs was recently replaced with Alladin-gs, version 4.03-7.  If
I run `lpr -Pcol1 bla.ps', I see with ps -eaxfwww that gs is run with
the following arguments:
/usr/bin/gs -sDEVICE=lvga256 -sDEVICE=cdj550 -q -r300x300 -sPAPERSIZE=a4 ...
It doesn't stop, and nothing gets printed.

Now who or what put -sDEVICE=lvga256 there?  I printed the environment
from the filter, and did not see a GS_DEVICE variable.  I tried to set
the GS_DEVICE variable in the filter, but it didn't help.  Even more
mysterious, if I run `filter870.ps < bla.ps', it works correctly!

I am completely at loss as to what is going on here.  Anyone with some
fresh ideas?

Eric Meijer

 E.L. Meijer (tgakem@chem.tue.nl)          | tel. office +31 40 2472189
 Eindhoven Univ. of Technology             | tel. lab.   +31 40 2475032
 Lab. for Catalysis and Inorg. Chem. (TAK) | tel. fax    +31 40 2455054

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: