[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Laptop modem in need of psychiatric help.


A friend has been having trouble with his modem.  It is a pcmcia card
modem for his Toshiba laptop.  Upon installing debian, we decided to try
and get pon working.  After setting up the scripts, we ran pon.  We
couldn't hear any sound of dialing from the modem, and running plog
displayed nothing.  Eventually the pppd process died.  By the way, I
should mention that the laptop and modem was working fine under slackware
which was installed previously.

Later we did get plog to give us some information.  It told us pppd had
failed because:
Oct 21 22:36:51 genoa pppd[239]: tcgetattr: I/O error

The next step was to see if minicom worked.  This is where some of the
bizzare behavior started to come into play.  For starters, we couldn't
make the speaker come on so it was very hard to tell what the modem was
actually doing.  ATM1 didn't seem to work.

Occasionally minicom would actually work and we could login to a remote
machine.  However after a while the connection would die with a complaint
of "NO CARRIER".  Other times we could not even dial up, again complaining
of "NO CARRIER".  While we were playing around with trying to turn the
speaker on with atm1, sometimes the modem wouldn't echo the characters we
typed.  When we turned the minicom local echo mode on, we got double
characters eg aattmm11.  Yet at other times minicom behaved normally in
this respect.

My friend also has a pcmcia ethernet card.  We tried removing this and
then using the modem.  This may have helped, but it is not clear.

As we had had some success in connecting with minicom, we tried running
pon again.  This time it just hung. 

My friend tried listening on a telephone in order to hear what was
happening with pon.  He found that sometimes a connection was made and a
handshaking process started.  But this never completed and pon was left
hanging.  Other times nothing happened. 

Well that's the story so far.  It seems like it's probably a hardware
problem but where how why what?  In the modem card?  With the cable? 
Clash of interrupts - how do you tell? 

Has anyone had any of these problems before?  Any ideas?



          "They told me I was gullible ... and I believed them!"

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: