[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Q] Several questions

as of this Sunday I downloaded and updated  almost of my
packages that now compiled with gnulibc6 (with exception
of X11 stuff).

I ran into a couple of problems and am not sure if I caused them.

1. After installing ldso, libc6, I installed libreadline2 -- that
some how deleted a link to my old readline that bash was dependent
on - so after I logged off I could not login into the system from 
anywhere -- bash was not executing.  Then I tried to go into
the system with the Debian installation diskettes (I have a version
that is based on kernel v 2.0.6) -- to see if the old libreadline
was saved somewhere but it was not.  I mounted my hd with
/usr/bin partition to see if I can run dpkg and install the latest
version of bash -- but dpkg did not run at all (this is what I do not
really understand: while in /target/usr/bin tried ./dpkg  and 
nothing happened). 
Before all that I tried to do the upgrade using dselect but the
update program exited with status 1 when installing libreadline --
this is why I started installing the lib myself.

I fixed the problem by doing two things:

a. substituted bash with ash (shell that comes on the installation disk)
-- this allowed my system to boot up to the point that hd
are mounted (all the init scripts use bash as a default shell)

b. changed my passwd file to allow root to login with cshell instead
of bash shell -- that allowed me get into the system and upgrade bash.

I just would like to know if next time I decide to do anything like
that -- what would be the preferred sequence of actions.

2.  After installing new bash -- I tried to compile my programs
nothing worked.  The problem was that my make files relied on 
determining operating system type by looking at OSTYPE env variable.
That variable was always defined as 'linux' now OSTYPE=gnu-linux.
I just wanted to know if this is now a standard and will be the
same for all the other linux distribution -- or should I use something
more stable to determine the OS type from makefiles.

3. gcc crashes consistently when compiling YACL (one of the C++
libraries I use) I get SIG 11 type of error.  Compiling kernel though
seems to be OK -- that is why I thing that there is something
wrong with a C++ portion of it.

I did install all the latest dev versions of glibc and g++ and the
latest CPP (I am not sure though if it has been updated for the
latest gcc)

Is there anything else I should install?

Thanks in advance,

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: