[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Lilo and Ext2 woes :)

Recently I had a major problem which began after I tried to make a few
modifications to my Lilo installation, and I'm convinced that my
configuration was the cause of it. :) My drive is partitioned as follows:
/dev/hda1 is an MS-DOS partition, which will soon have Win95 installed.
Hda2 is a Linux partition and hda3 is swap.
Anyhow, I read somewhere that installations of DOS and Windows refuse to
tolerate other operating systems and will remove Lilo from the boot
sector, and that the best thing to do was to change your bootable
partition to the Linux partition and install Lilo onto the super block of
that partition, from which point it would handle the boot process. So, I
tried this, and that was when the problems began. :)
Before I explain what happened, though, I'll give some background. I used
to use Slackware on a 486, and could never get Lilo working properly. So,
one time, I had accidently set boot=/dev/hda1 in my lilo.conf. (on that
computer, hda1 was an MS-DOS partition.) Whenever I attempted mounting
that partition, I received an error that there were either too many
mounted filesystems, or that the superblock on the filesystem was corrupt.
Because I was able to mount my dos partition before without unmounting
anything, I decided that there were not, in fact, too many mounted
filesystems and that the Lilo installation had caused this error. And,
sure enough, a 'lilo -U' removed the code, and the partition was mountable
Well, anyhow, I thought that this error would not occur on an Ext2
filesystem, so I editted my lilo.conf and changed 'boot=/dev/hda' to
'boot=/dev/hda2', not remembering my previous blunders. And it was then
that my problems began. When I boot my computer, Linux seems to begin
loading and I hear my speakers come to life, indicating that my sound card
is being initialized, but for some reason my root Ext2 filesystem appears
to be mounted as an MS-DOS filesystem, and a 'Cannot initialize console'
message appears. (I think that's what it was.)
So, I pulled out my trusty rescue disk, intending to purge the Lilo
installation from the superblock. But, after attempting to mount
/dev/hda2, I was given the exact message that I listed above, when I tried
mounting the DOS partition which I had accidentally installed Lilo on. I
tried using e2fsck to copy a backup superblock, but that did not work
So, my question is, how can I uninstall Lilo from a partition that I no
longer have access to? I have a RedHat 4.1 CD with a live filesystem on
it, so I can copy any needed utilities (I.e. Lilo, pico, etc.) onto the
Debian rescue disk from the CD. One idea I had was to create a simple
/etc/lilo.conf with a single line, 'boot=/dev/hda2' and then running 'lilo
-U' and hoping that it would return the superblock to a bootable state,
but I am doubtful that this will work because of the lack of a /boot
directory from my original partition. Is there some way to identify the
code that Lilo would have written, and to remove it from the superblock?
If so, are there any (DOS, preferably) programs that could repair this for
Or, is the only solution a fresh install? If so, would it be possible to
recover anything off of the partition before I re-format it? There are
some projects that I had stored which I would really hate to redo, as well
as my /etc/ppp.chatscript, which is pretty extensive and took me several
days to write, and took quite a toll on my sanity and patience. :)

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: