[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: LILO and dos partitions

> I'm installing Debian over what was formerly a Slackware partition (It's
> been reformatted, thank goodness) and I'm stumped as to how I'm supposed
> to get LILO to work with my dos partition.  Right now, my /etc/lilo.conf
> is:
> compact
> boot=/dev/hda1
> vga=normal
> delay=20
> image=/vmlinuz
>   label=linux
>   root=/dev/hda2
>   read-only
> other=/dev/hda1
>   label=dos
>   table=/dev/hda
>   loader=/boot/any_d.b
>   I've tried chain.b for the dos partition, and chain.b with all the extra
> junk in the 0.20 documentation (Is anyone working on updating the lilo deb
> file to 0.20?).  Whever I attempt to boot the dos partition, I get a
> screen filled with repetitions of "01 ".  Linux boots fine, and, using an
> dos boot disk, I can find the dos file system.  Linux cannot find it; it
> says that it can't find a valid MSDOS filesystem.

For what it's worth, my dos bit just looks like this:


The repeating 01 01 01... guff is [from memory] a large/lba probem. Try
changing your hd settings in bios to lba or large. [Obviously, whichever
one it ISN'T at the moment...] See if that helps.

You'll probably have to rerun lilo afterwards. 
>   On a related note, WTF is that "1FA:" thingy that I got when I tried to
> reboot Debian for the first time?  It didn't want to do anything.  I
> eventually rebooted and ran lilo, after which it worked fine unless I held
> down shift early in the boot sequence (in which case I got the "1FA:"
> thing for a moment, and then it went into LILO).

Same thing as above I think. [Emphasis on the "I think" part. It's late,
I could well be wrong]

So, give them a go, see what happens. If it doesn't work, I'm sure someone
else will jump in with another possible solution.


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: