[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

/dev/ttyS3-permission for efax-user


I am nou using Linux for about 8 months and previously could not get
fax software running on my Debian-system.  I tried again last night
and enjoyed more success than previous times trying to get efax
running using a Zoltrix 14400 modem.

When I tried "fax send -m foo" as user, I received the following error

efax: removed stale lock /var/lock/LCK..ttyS3 from pid 373
efax: Error: tty device open
/dev/ttyS3:Permission denied
efax: done, returning 2

I then (as su) typed 
  chmod u+rw /dev/ttyS3

but it did not help.

When I run the fax command as su the there is no similar problem: 

efax: removed stale lock /var/lock/LCK..ttyS3 from pid 416
efax: opened /dev/ttyS3

ls /dev/ttyS3 produces

rcrw-rw----   1 root     tty        4,  67 Apr 30 09:05 /dev/ttyS3

Can somebody help me please.  

Johann Spies

Windsorlaan 19
Suid Afrika (South Africa)
Tel. Nr. 0331-46-1310

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: