[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ncpfs module and kernel recompile

Following my previous email and the reply on the list I tried to recompile
the kernel. The problems I had are as follws 

I can create the .config file using make config. No problem. 
Then I run the make-kpkg command from the kernel-package
I am in /usr/src/linux which is a symlink for /usr/src/kernel-2.0.29
The exact syntax I use is make-kpkg --zimage --revision custom-1.0
buildpackages . This runs apparently fine. I use he --zimage option
because from what I have in /boot the kernel must be in a file called
vmlinuz I assume that this means that the image must be compressed. 
Problem No. 1 When I use for pactise the .config file which comes with the
kernel-source I get a loop when the variable CONFIG_DLCI_COUNT
is processed It says something about maximal counts. OK so I edit the
.config file and unset the DLCI variables. I don't need them anyway
Problem  2
 Then the thing runs ( both for the standard .config and my own .config 
and gives
me a vmlinux file larger thatn 512 Kb and so lilo says it is too big
and will not include it in the boot record or whatever for booting. So it
is not compressing the image. I tried to gzip the thging myself. Probably
stupid,  at boot time it said Loading kernel .. 
and hung there. So I don't know what to do. I  need to compile my
own kernel since the sound module has disappeared from the modules section
too when I upgraded from 2.0.0 to 2.0.27
I would be grateful for any help and ideas.,


Reply to: