[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Solved - Cannot get full speed download on ppp

This is a follow up to my previous problem since i have not given up.

I tried to download file to /dosa mounted on /dev/fd0. The result
was as good as downloading to /dev/hdc1 ( so floppy can do better than
my /dev/hda ?? of course i do not believe it).

After a few days, I started to think about kernel config. When i
checked, i realised that the kernel i only enabled 'enhanced ide
driver'. I thought this should look after /dev/hda without problems.

Anyway, this time i reenable the old hard disk driver to look after
/dev/hda (the help said that the first drive will be managed
by this driver and the rest will be managed by the enhanced 
ide driver). Then i did a recompilation of the kernel and run lilo.

After reboot, I tried downloading file again onto /dev/hda and this
time transfer rate back to normal of 3.1k bytes per second. ifconfig
showed that ppp0 did not have any errors.

I guest it may be my mother board's ide controller not working well
with the enhanced ide driver for the first hard disk.

For those who are interested, the controller is ALi14xx series.

Now I am very happy with my linux box.

Paul Chau wrote:
> Thank you John,
> Just more info about it. Last night i did not give up and tried any
> BIOS settings i could think of but still the problem existed except
> when i tried:
>    chdir to /extra ( this is on /dev/hdc1 )
>    tried a ftp session to retrieve a zipped file - lo and behold, i
>    can download it ( 300K size ) at 3.1K bytes per second.
>    quit to session and cd to my home directory ( /dev/hda )
>    started a ftp session and download the same file to that directory
>    BAD now, the transfer rate  was 2.6 K bytes per second.
> This could mean that there are some problems with my /dev/hda which is
> a quantum fireball 1G disk. So far i did not get bad sectors in dos,
> linux always started and said disks clean. PS: the drive on /dev/hdc
> is an old Maxtor 345 M harddisk (ATA mode 2 ).
> I may try your suggestions later and hope that will solve download
> problem.
> Regards.
> Paul
> John T. Larkin wrote:
> >
> > > I don't what i have done to my system. Recently i found that my
> > > download speed from our server at most can give me 2.6k byte/s ftp.
> >
> > You should try two things:
> > 1) Use hdparm to optimize the performance of your disks.  I recomend
> >    the '-u' option to unmask the IRQ for data transfers.  Be careful
> >    with this, as it (supposedly) has been known not to work on some
> >    systems and causes severe data corruption.
> > 2) Use irqtune to give the serial port the highest priority.
> >
> > > I used to be able to
> > > get 3.1K bytes/s downloading  compressed file.
> > I really don't know why you used to be able to get this performance,
> > but no longer (unless you just happened to hit a really busy time of
> > day, and your ISP couldn't get data fast enough).  My 386-40, with an
> > old 8250 uart and external 28.8 modem, can get thru-put of 2.8ish for
> > transfers.  This generates about 6000 interupts per second, and pretty
> > much pushes the limits of the old hardware (a newer 16550 uart would
> > help by greatly reducing the number of interupts).
> > I'm slightly confused by your situation, because you really should
> > have no problems with a p-133 and internal modem or 16550 uart on the
> > serial port.
> > Anyway, try it, and if it helps....
> >
> > Good luck,
> > --
> >                                 - John Larkin
> >                                 - jlarkin@hmc.edu
> >                                 - http://aij.st.hmc.edu/~jlarkin

Reply to: