[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: can't umount /usr(/dev/hdb3)

On Sat, 29 Mar 1997, Syrus Nemat-Nasser wrote:

> On Sat, 29 Mar 1997, David Puryear wrote:
> > I upgrade a lot of packages, don't know exactly which ones though,  and now
> > shutdown -h now and umount will not unmount /usr(aka /dev/hdb3). It gives me
> > same error:
> >         umount: /dev/hdb3: device is busy 
> > 
> > Does anyone have any idea as to what is causing this?
> If you are in any of the mounted directories (including the top, e.g. 
> /mnt), then umount would give this message and refues to unmount the 
> device.
I don't know that this is strictly true. For instance, my fstab mounts
/usr from a seperate device, and, I assume, unmounts it during shutdown.
At the time of shutdown, all my users are logged in and sitting in their
user accounts. Now, I know that shutdown kills all the users off before it
does the unmounts, so by then they are not an issue. I assume all root
processes are killed off by then as well.
I had a problem recently of this type. I tried to unmount /cdrom and was
told that /dev/scd0 was busy. After going to each account logged in and
checking for processes using /cdrom, and finding none, I eventually logged
out all users but root at VC1 and was still unable to unmount. Since I
REALLY wanted the cd that was in the drive, I shut the drive off and then
back on. This let the drive open it's door so I could retrieve the cd, but
created problems for the system (i/o errors from df) until I rebooted.
I have learned since that I could probably have 'rmmod'ed the driver and
re-'insmod'ed it, but still have no idea why the system thought that the
device was busy.

Waiting is,

_-_-_-_-_-_-                                          _-_-_-_-_-_-_-

aka   Dale Scheetz                   Phone:   1 (904) 656-9769
      Flexible Software              11000 McCrackin Road
      e-mail:  dwarf@polaris.net     Tallahassee, FL  32308

_-_-_-_-_-_- If you don't see what you want, just ask _-_-_-_-_-_-_-

Reply to: