[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Samba 1.9.16p11



> I have upgrade to Samba 1.9.16p11.
> After thus I have no more connection to servicec with password:
> 
>  first SMBtconX failed, trying again. ERRSRV - ERRbadpw (Bad password -
>  name/password pair in a Tree Connect or Session Setup are invalid.)
>  SMBtconX failed. ERRSRV - ERRbadpw (Bad password - name/password pair in a
>  Tree
>  Connect or Session Setup are invalid.)
>  Perhaps you are using the wrong sharename, username or password?
>  Some servers insist that these be in uppercase
> 
> Any comments?
> 
> Mirek Kwasniak
> 

I believe the new Samba (in unstable) uses PAM (pluggable authentification
modules).  Klee Dienes (the maintainer) mentioned in debian-devel that
the following lines need to be added to /etc/pam.conf:

samba   auth     required       /usr/lib/security/pam_unix_auth.so debug
samba   account  required       /usr/lib/security/pam_unix_acct.so
samba   session  required       /usr/lib/security/pam_unix_session.so
samba   password required       /usr/lib/security/pam_unix_passwd.so

Hope this fixes it.

Cheers,

 - Jim

Attachment: pgplZnR8YhEm7.pgp
Description: PGP signature


Reply to: