[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help! Messed up my MBR, don't have backup!

I built a new kernel (2.0.29) and copied it from arch/i386/boot
to /boot.

I then made a sym link zImage->/boot/zImage.

Next I ran lilo which is were I had a total brain failure.

I built the kernel above on my P90 for a 386.

I forgot what machine I was on when I ran lilo!  I was doing all
of this from a xterm on my Sun logged into my P90.

Now my P90 is screwed up.  Here is how my P90 is setup:
/dev/hda1 Ide dos drive 500+M
/dev/hdb1 Ide linux drive 130M

I use a boot floppy to boot Debian Linux 1.2 on my P90.
I made the boot floppy by cp /usr/src/linux/arch/i386/boot/zImage /dev/fd0.

I tried using lilo to forget about my linux drive and just boot
dos but I think I ended up messing things up.  I tried:

When I boot the machine I get LILO then unexpected EOF loading dos.

Is there any way I can rebuild my MBR so my dos partition works
again?  Next time I will remember what machine I am on before 
I do something this stupid again.

I hope I can recover from this or else I'm in trouble since my
P90 is my machine at work! :(



TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: