[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bad superblock (fwd)

Hello, all,

I'm having unexplained problems booting my debian box. I shutdown linux
yesterday morning and booted win 95 from /dev/hda1. When I tried to reboot
linux (/dev/hda2) in the evening using lilo, I got nothing but the
"starting linux" statement. I used the base rsc1440.bin disk (my boot
floppy didn't work) to boot linux. I ran "e2fsck /dev/hda2". I got:

e2fsck: Bad magic number in superblock while trying to open /dev/hda2. 

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem, then the superblock is corrupt and you might trying running
e2fsck with an alternative superblock: 
e2fsck -b 8193 <device>

This last suggestion gives:
Attempts to read block from filesystem resulted in short read while trying
to open /dev/hda2...

cfdisk tells me that this still is a legit filesystem/partition.

My box is a pentium 150 pci with pnp bios, 2 gig HD and 32 MB memory. 
/dev/hda1 = msdos
/dev/hda2 = ext2
/dev/hda3 = linux swap

Advice, kind people?


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: