[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse : can't locate module char-major-10



> Hello All,
> 
> I am new to Linux and of course new to the Debian distribution.
> 
> Recently I tried to install X on my box using the vga16 server. When
> started, the server immediately die with a message "Cannot open
> mouse : (no such device).
> 
> Because X is a rather complex package, I tried to troubleshoot my
> mouse problem using gpm. The result was the same as with X, now the
> message is gpm : /dev/psmouse :  No shuch device. Because psmouse is
> a symbolic link a also tried psaux and because it still didn't work,
> I even tried /dev/msmouse and /dev/inportbm (in fact this is a
> non-sense because my mouse is a PS-2 style).
> 
> The problem is not the mouse hardware, because under Windows95, the
> same mouse on the same PC work ok. It is discovered as a PS/2
> compatible mouse using interrupt 12.
> 
> The computer is a Gateway 2000 P100. I think they use an Intel
> Alladin mother-board, but I am not completly sure. The mouse
> is a Microsoft "Mouse Port Compatible 2.0"
> 
> I had also a look at /proc/devices and I didn't find any mouse
> device there. Also /proc/interrupts do not show any entry for
> interrupt 12.
> 
> Finally I found that every time a started X or gpm, I got an entry
> in daemon.log : "modprobe : can't locate module  char-major-10
> 
> So it seems that I need to load a module for my mouse.
> In /usr/lib/module_help/modules I found that modules
> should exist for psaux and mouse, however I didn't find any
> psaux.o or mouse.o on my system.
> 
> Now I am stuck. I only see two possibilities :
> 
> 1)I really need to load psaux.o and mouse.o; but where can I found
>   those files?
> 
> 2)The mouse driver is build in the kernel and for some reason the
> mouse is not detected at boot-up. How can I force the mouse
> configuration?
> 
> I have really no idea which of those two possibilities is correct.
> As I am new to Linux maybe I made a stupid mistake.
> 
> All the software was loaded from the stable subtree of the 
> distribution. Kernel is 2.0.6.
> 
> Any help would be appraciated.
> 
> Thanks,
> 
> Andre Dewevre
> Email : Andre.Dewevre@ping.be


I had the same problem.  As far as I know, Debian does not include 
PS/2 driver as a module, so you'll have to recompile your kenel :(.

--
Igor Grobman      igor@vaca.net                                        
Life!  Can't live with it, can't live without it...                        

--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com


Reply to: