[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Infomagic Developers Release - IDE installation problems

Hi Guys and Gals?,

I have recently purchased the aforementioned developers resource to
replace my old Slackware 1.0 professional. I trashed the old system
by mistake and decided to replace it instead with a new version.

I have a problem with the installation with both Red Hat and with the
Slackware distributions.

My hardware is as follows :

486DX33 - breed unknown
20 Mb RAM
S3 Video Card 1 Mb RAM - breed unknown
Promise Disk Controller DC4030VL-2 4Mb Cache RAM
Maxtor 72004AP with the following partitions (as seen by Old slackware 
fdisk) it is the 2.1 Gb Maxtor.

I am using the DDO software that comes with the drive because I do not 
have LBA on my BIOS. This drive and software combination was acceptable 
under my old Slackware distribution but does not seem acceptable to any 
of the kernels that I have on the disks with one exception (Red Hat 

hda1 = DOS FAT (Drive C:)
hda2 = DOS Extended
hda3 = Linux Root
hda4 = Linux /usr
hda5 = Linux swap
hda6 = DOS FAT (Drive D:)
hda7 = Windows NT

1) Redhat. The problem that I have with this is after having created the
Boot image and both Ramdisks, the floppy then boots happily and off we
go. The Ramdisks are loaded and the installation proceeds. The
installation then goes off the rails and stops with the message

mount: fs type umsdos not supported by kernel

Error: press enter for more info

The following command
mount -t umsdos -o ro /dev/fd0 /bootdisk

exited with code 1

I don't really know why? I am using the Boot0000.img and have copied the
old-IDE.ker file as per the documentation. The boot process appears to
recognise the CD ok and asks if I have a color monitor etc. just prior 
to ceasing to work.

2) Slackware also has a problem. The system will recognise my IDE drive
but cannot read the partition table please see above note re kernels 
that recognise it. The last kernel that I compiled
under my old slackware had the Old IDE enabled, thus able
to recognise the partition table. I still have the boot disk for this
kernel (1.1.59) and have booted under this and am able to utilise
the root diskette that was generated with it. I have tried to use the
boot:ramdisk root=/dev/hda3 (which is the root partition) but
I get the boot process failing with an error message "child process
failed count nnn" where nnn starts at 1 and continues ad infinitum.

I have tried the installation under my old kernel (1.1.59)
but this does not seem to install properly (possibly the tag files
are causing it a problem) and I think the IDE situation has a lot to do
with it.

I have read through the ide.txt documentation and have tried a few of
the boot switches that are there with no success. During system startup
the ide controller is recognised :
ide0 at 0x1f0-0x1f7,0x3f6 IRQ=14

and then states the partition table is invalid. fdisk cannot read the 
partition table correctly and the installation comes to a halt.

The Debian release on the CD also has exactly the same problem as above.

I have actually managed to install RED HAT with a single floppy via 
CDROM using a kernel that I have saved in my drive C:\loadlin from the 
old version. This kind of worked until it came time to copy the kernel 
from the boot floppy when the umsdos problem arose again.

To say I am frustrated is an understatement please help!

Please reply via email because I don't have time to scan all the linux 
newsgroups. Thanks kindly



David Logan
33A Charles Street
Erskineville NSW 2043

Phone (02) 9557 3262
Fax (02) 9550 5770

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: