[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Need help with NIS: close, but it don't work yet

A year ago I tried out NIS and had it working on my Slackware system.
(I didn't actually need to use it, so I only ran it for a day.)
I can't seem to get it to work now. When ypbind is running, commands
that should trigger a name lookup don't even cause the lights on my
modem (ppp) or ISDN box to blink with any activity. Same is true when
I execute ypbind itself: no line activity.
Routing is OK, since I can telnet, ftp, etc to remote hosts by using
IP addresses rather than names.

Running the following commands:

/etc/init.d/nis start
rpcinfo -p localhost
rpcinfo -u localhost ypbind
ps -auwwx|grep yp

gives this output:

# /etc/init.d/nis start
Setting NIS domainname to: veritas
Starting yellow page services: ypbind 
# rpcinfo -p localhost
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100007    2   udp    748  ypbind
    100007    2   tcp    750  ypbind
# rpcinfo -u localhost ypbind
program 100007 version 2 ready and waiting
# domainname
# ps -auwwx|grep yp
root      1527  0.0  1.2   828   388  ?  S   23:55   0:00 /usr/sbin/ypbind 
root      1529  0.0  1.2   832   384  ?  S   23:55   0:00 /usr/sbin/ypbind 

Is is strange that ypbind appears twice?

Various commands give these error messages:

# ypcat passwd
YPBINDPROC_DOMAIN: No bound server for domain veritas
No such map passwd.byname. Reason: Can't bind to server which serves this
# ping rickm
YPBINDPROC_DOMAIN: No bound server for domain veritas
ping: unknown host rickm
# ypwhich
can't yp_bind: Reason: RPC failure

I get this message in /var/adm/daemon.log (remember, the lights never 
blink on the modem):

Oct 10 00:06:01 localhost /usr/sbin/ypbind[28920]: Running in restricted
mode -- request to bind domain "veritas" rejected. 

I have "+::::::" in /etc/passwd and "+:::" in /etc/group.

order hosts,nis
multi on

In the file /etc/init.d/nis, I've tried

start-stop-daemon --start --quiet --exec ${NET}/ypbind -- -S

and just 

start-stop-daemon --start --quiet --exec ${NET}/ypbind

in case there's a problem with broadcasting.

I've installed the latest unstable versions of netbase, netstd and nis:
  -rw-rw-rw-   1 root       206560 Sep  1 08:26 netbase_2.06-1.deb
  -rw-rw-rw-   1 root       660206 Aug 30 18:27 netstd_2.07-1.deb
  -rw-rw-rw-   1 root        90118 Oct  3 06:47 nis_2.00-1.deb

With my ISDN:

# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface   U      1500 0          0 eth0       U      3584 0          0 lo         UG     1500 0          0 eth0

With my PPP:

# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt  Iface UH     1500 0          0  ppp0       U      3584 0          0  lo         UG     1500 0          0  ppp0

Note that with ppp, I'm on the same subnet as the NIS server, but with
ISDN I'm on a different one. Both ways, I have this same problem.

The nis server is there:

# ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=253 time=1037.5 ms
64 bytes from icmp_seq=1 ttl=253 time=57.3 ms
64 bytes from icmp_seq=2 ttl=253 time=27.6 ms
64 bytes from icmp_seq=3 ttl=253 time=28.1 ms


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: