[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: The "*" character (was: Latex )

Hi Mark --
You said:
> in response to: 
> >Hi Mark --
> >You asked:
> >> because I'd said:
> >> >It would be helpful if you could tell us what version of the packages
> >> >you have installed.  For example, if you would run this commands:
> >> >
> >> >      dpkg -l *tex*
> >> 
> >> I noticed that this doesn't work under tcsh, but does work under
> >> bash.  Is there a difference between how the * character is treated
> >> under the two shells?
> >
> >
> >What I'd written was actually not right for either shell.
> >
> >I should have written:
> >
> >         dpkg -l "*tex*"
> >
> >The problem is that without the quotes, the shell expands the argument
> >first, before handing it to dpkg.  If there's a file in your current
> >directory with a name that matches *tex*, then that file, and only that
> >file, is fed to dpkg.  This is not what's intended of course.
> >
> >So I tried the correct usage (with the quotes) under tcsh and it worked
> >fine.
> But the interesting thing is that dpkg -l *tex* actually _works_ when
> run under bash, leading me to think that the bash shell doesn't expand
> the argument first.
Are you sure you tried dpkg -l *tex* in a directory where you know there's 
a file whose name matches the pattern *tex*, and whose name is not that 
of a debian package?  On my system both bash and tcsh behaved the same way.


Reply to: