[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

modules/kerneld problem



I recently upgraded several packages in the unstable directory including the
modules package.  I am running kerneld.  After the upgrade, when I tried 
to execute pppd I get "Sorry - this system lacks PPP kernel support".  
When I try to do insmod ppp I get:

slhc_free undefined
slhc_init undefined
slhc_toss undefined
slhc_uncompress undefined
slhc_remember undefined
slhc_compress undefined
Loading failed! The module symbols (from linux-1.99.5) don't match your 
linux-1.99.5

I suspected the problem might have been the new /etc/conf.modules file so
I put the old one back.  After rebooting, it worked again as before.  But,
for some silly reason I didn't believe it was a problem with the new
/etc/conf.modules and moved the new one back over the old one that was
working.  Now I have the same problem again.  Are other people having this
problem?  I can still do "insmod slhc ; insmod ppp" and have things work,
but it's not loaded automatically by kerneld anymore apparently because
some dependency information is wrong. 

Any thoughts anyone?

Gerry
gerry@blue.intele.net


Reply to: