[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Instalar drivers Nvidia



El 12/03/2012 11:06, José Maldonado escribió:
El día 12 de marzo de 2012 08:55, Yoandy Madrazo Gómez
<yoandy@astisur.telemar.cu>  escribió:
Saludos lista, resulta que tengo una vieja Nvidia Vanta y no he podido
instalarle los drivers para habilitarle la aceleración 3D, le estoy
instalando el último driver que encontré en nvidia.com
NVIDIA-Linux-x86-71.86.15.pkg1.run, él se instala bien pero no me carga el
driver, incluso el módulo del kernel funciona bien, el Xorg.log me devuelve
esto

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.29-dsa-ia32 i686 Debian
Current Operating System: Linux andromeda 2.6.32-5-686 #1 SMP Mon Jun 13
04:13:06 UTC 2011 i686
Kernel command line: auto BOOT_IMAGE=Linux ro root=801
Build Date: 19 February 2011  02:37:36PM
xorg-server 2:1.7.7-13 (Cyril Brulebois<kibi@debian.org>)
Current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar  8 19:04:29 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in
"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType").
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in
"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType".
    Entry deleted from font path.
    (Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType").
(**) FontPath set to:
    /usr/share/fonts/X11/misc,
    built-ins,
    /usr/share/fonts/X11/misc,
    built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or
'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x81ecca0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:1:0:0) 10de:002c:1043:fffe nVidia Corporation NV6 [Vanta/Vanta
LT] rev 21, Mem @ 0xee000000/16777216, 0xe2000000/33554432, BIOS @
0x????????/65536
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) Open APM successful
(II) "extmod" will be loaded. This was enabled by default and also specified
in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in
the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in
the config file.
(II) "record" will be loaded. This was enabled by default and also specified
in the config file.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded. This was enabled by default and also specified
in the config file.
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: XFree86 Server Extension
    ABI class: XFree86 Server Extension, version 0.1
(II) NVIDIA GLX Module  71.86.15  Tue Jul 19 10:54:58 PDT 2011
(II) Loading extension GLX
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.7, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol:
AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (loader failed, 7)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
     at http://wiki.x.org
  for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.

Resulta que he visto en google este error por montones pero no he visto
ninguna solución, si alguien la ha logrado instalarla por favor que me diga
como hacerlo. Estoy usando debian squeeze

Yoandy


--
To UNSUBSCRIBE, email to debian-user-spanish-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: 4F5DF92E.6080603@astisur.telemar.cu">http://lists.debian.org/4F5DF92E.6080603@astisur.telemar.cu

Estimado olvídese de los drivers Nvidia para su tarjeta, es demasiado
vieja, Nvidia ya no ofrece soporte para esas tarjetas debido a los
cambios en el kernel linux y en Xorg, y el driver nouveau no soporta
esas tarjetas, pero podrías probar con el driver nv,  pero si estás en
wheezy olvídate porque no existe ese paquete para esa rama.

Bueno veré que tal procede knoppix 6 y si me pone la aceleración, si no tendré que resignarme, lo que si no vuelvo es a instalarle windows ;-), el driver nv me funciona bien pero necesitaba la aceleración 3d, tendré que hacer como los niños chiquitos, si no se puede no se puede jajajaja.

Saludos



Reply to: