[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[dparsons@debian.org: Incorrect version of xserver-xorg in unstable]

Perdón por enviar esto en inglés, pero es un aviso importante y no
tengo tiempo para traducirlo.

----- Forwarded message from Drew Parsons <dparsons@debian.org> -----

Subject: Incorrect version of xserver-xorg in unstable
From: Drew Parsons <dparsons@debian.org>
Date: Tue, 22 Aug 2006 22:10:20 +1000

Summary:  - Unstable users, 
                     please place xserver-xorg-core 1:1.0.2-9 on hold,
                     or retrieve it from testing
                     or fetch your latest video driver from experimental.

          - Users of testing and stable are not affected.

An upload of xserver-xorg 1:1.1.1-3 was incorrectly made to unstable
today. The intended target was experimental.  The correct current
version for unstable is 1:1.0.2-9.

The chief binary package affected is xserver-xorg-core.  Other affected
packages are xdmx, xdmx-tools, xnest, xserver-xorg-dev and xvfb.

1:1.1.1-3 corresponds to X11R7.1, while 1:1.0.2-9 belongs to X11R7.0.
The consequence of this upload is that old X11R7.0 video drivers in
unstable will fail to load and the Xserver  will fail to start, with an
error message similar to:

(II) LoadModule: "i810"
(II) Loading /usr/lib/xorg/modules/drivers/i810_drv.so
(II) Module i810: vendor="X.Org Foundation"
        compiled for 7.0.0, module version = 1.5.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 0.8
(EE) module ABI major version (0) doesn't match the server's version (1)
(II) UnloadModule: "i810"
(II) Unloading /usr/lib/xorg/modules/drivers/i810_drv.so
(EE) Failed to load module "i810" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please choose one of the following actions as a temporary workaround:

1) place xserver-xorg-core 1:1.0.2-9 (and the other xserver-xorg
packages) on hold


2) if you have already been affected then grab your xserver-xorg
package[s] from testing and downgrade back to  1:1.0.2-9


3) come join the future and grab your new video driver from experimental

Versions of latest video drivers and other X11 packages in testing,
unstable (old X11R7.0 versions, both) and experimental (new X11R7.1
versions) are summarised at

We apologise for the inconvenience.  Discussions are underway at
debian-devel to further evolve our processes to help reduce the
likelihood of this mistake being made again in the future.

X11R7.1 is nearly ready for unstable in its own right and should have
arrived within the fortnight.

Drew Parsons
on behalf of the X Strike Force

----- End forwarded message -----

Rodrigo Gallardo
GPG-Fingerprint: 7C81 E60C 442E 8FBC D975  2F49 0199 8318 ADC9 BC28

Attachment: signature.asc
Description: Digital signature

Reply to: