[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problema de dependencias de módulos



Hola a todos!
Tengo un "ligerillo" problema con algunas dependencias de módulos. Compilé el kernel
2.4.2 y algunas cosas las tengo como módulos, pues bien, depmod dice lo siguiente
(al arrancar y también ejecutando "depmod"):

depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/fs/nfsd/nfsd.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/ip_gre.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/ipip.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_conntrack.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ipchains.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ipfwadm.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ipt_REJECT.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/iptable_filter.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/iptable_mangle.o
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/iptable_nat.o

He comprobado a mano (/lib/modules/2.4.2/modules.dep) que están todos los módulos 
que se indican como dependencias para los que se queja depmod, así que realmente no
sé que puede ser. Por si sirve para algo, aquí está también la salida que "depmod -e"
me da:

depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/fs/nfsd/nfsd.o
depmod:         nfsd_linkage
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/ip_gre.o
depmod:         nf_hook_slow
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/ipip.o
depmod:         nf_hook_slow
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_conntrack.o
depmod:         nf_unregister_hook
depmod:         nf_unregister_sockopt
depmod:         nf_register_hook
depmod:         nf_register_sockopt
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o
depmod:         nf_unregister_sockopt
depmod:         nf_register_sockopt
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ipchains.o
depmod:         nf_unregister_hook
depmod:         nf_unregister_sockopt
depmod:         nf_register_hook
depmod:         nf_register_sockopt
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ipfwadm.o
depmod:         nf_unregister_hook
depmod:         nf_unregister_sockopt
depmod:         nf_register_hook
depmod:         nf_register_sockopt
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ipt_REJECT.o
depmod:         nf_hook_slow
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/iptable_filter.o
depmod:         nf_unregister_hook
depmod:         nf_register_hook
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/iptable_mangle.o
depmod:         nf_unregister_hook
depmod:         nf_register_hook
depmod: *** Unresolved symbols in /lib/modules/2.4.2/kernel/net/ipv4/netfilter/iptable_nat.o
depmod:         nf_unregister_hook
depmod:         nf_register_hook

Una vez jugué con eso de programar módulos para el kernel, pero ahora mismo (ni creo
que nunca antes tampoco) no se me ocurre que puede ser.
Muchas gracias por anticipado:

October

PS: por lo demás, parece que todo funciona con normalidad, aunque de momento no uso
ninguno de estos módulos, esta es la salida para, por ejemplo, "modprobe ip_tables":

/lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol nf_unregister_sockopt
/lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol nf_register_sockopt
/lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.2/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed

(si es que no sé ni por donde empezar ... )



Reply to: