[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Habilitar camera digital firewire



olha esta agere tive muito problema pra usar. tinha hp que veio com ela tive que trocar, como disse antes:

o  básico seria ver qual chipset da firewire...em alguns laptop HPs tive
problema com uma marca.

se for chipset da ricoh e muito boa.


recomendo tu compilar o kernel com suporte a firewire ligado e tentar.

pode ter melhorado o suporte.

problema que tinha e que começava a capturar mas depois parava.

Em 17-10-2011 07:29, Ronaldo Reis Júnior escreveu:
ola,

Bom tentei fazer isto mas não tem nenhum destes dispositivos presentes.

root@biocomp-21:/home/lupa# find /lib/ -name *1394*
root@biocomp-21:/home/lupa#

Veja a placa sendo reconhecida:

3:00.0 FireWire (IEEE 1394): Agere Systems FW643 PCI Express1394b Controller (PHY/Link) (rev 08) (prog-if 10 [OHCI])
        Subsystem: IOI Technology Corp FWB-PCIE1X20
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at febff000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 3
        Capabilities: [4c] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [60] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [170] Device Serial Number 00-02-7a-16-00-00-2b-7a
        Kernel driver in use: firewire_ohci

olhei no kernel e parece que não tem nada 1394 sendo compilado, vejam:

root@biocomp-21:/home/lupa# cat /boot/config-3.0.0-2-486 | grep 1394
# IEEE 1394 (FireWire) support
# Supported FireWire (IEEE 1394) Adapters
# CONFIG_PROVIDE_OHCI1394_DMA_INIT is not set

Olhei em um kernel mais antigo e é a mesma coisa:
root@biocomp-21:/home/lupa# cat /boot/config-2.6.32-5-686 | grep 1394
# IEEE 1394 (FireWire) support
# CONFIG_IEEE1394 is not set
# CONFIG_PROVIDE_OHCI1394_DMA_INIT is not set

Vejam os modulos que estão carregados:

root@biocomp-21:/home/lupa# lsmod | grep firewire
firewire_ohci          26881  0
firewire_core          43114  1 firewire_ohci
crc_itu_t              12331  1 firewire_core


E vejam o que tem no kernel

root@biocomp-21:/home/lupa# find /lib/ -name *firewire*
/lib/modules/3.0.0-2-486/kernel/drivers/media/dvb/firewire
/lib/modules/3.0.0-2-486/kernel/drivers/firewire
/lib/modules/3.0.0-2-486/kernel/drivers/firewire/firewire-ohci.ko
/lib/modules/3.0.0-2-486/kernel/drivers/firewire/firewire-core.ko
/lib/modules/3.0.0-2-486/kernel/drivers/firewire/firewire-net.ko
/lib/modules/3.0.0-2-486/kernel/drivers/firewire/firewire-sbp2.ko
/lib/modules/3.0.0-2-486/kernel/sound/firewire
/lib/modules/3.0.0-2-486/kernel/sound/firewire/snd-firewire-lib.ko
/lib/modules/3.0.0-2-486/kernel/sound/firewire/snd-firewire-speakers.ko

Será que vou ter que recompilar o kernel para a minha camera firewire funcionar? Achei estranho pois a placa em si parece ter sido reconhecida normalmente. Ja instalei o kino mas a camera não é reconhecida.

estou tentando evitar ter que particionar meu HD e instalar o Windows, estou tentando até no virtualbox, mas acho que ele não tem suporte a firewire, pelo menos eu não consegui fazer com que ele encontrasse o dispositivo e reconhecesse a camera no windows instalado no virtualbox.

Se alguem tiver mais alguma dica que eu possa testar será bem vinda, seja reconhecer no linux ou fazer ela ser aceita pelo virtualbox.

valeu
Inte
Ronaldo


Em 14 de outubro de 2011 19:56, Sorocaos <sorocaos@gmail.com> escreveu:
Em 14-10-2011 12:26, Ronaldo Reis Júnior escreveu:
> Pessoal,
>
> utilizo o debian unstable, estou com a última versão do kernel. Tenho
> uma camera digital firewire e estou tentando fazê-la funcionar no
> linux. O linux reconheceu a placa firewire, mas ainda não consigo
> fazer ele reconhecer a camera ieee1394b

o  básico seria ver qual chipset da firewire...em alguns laptop HPs tive
problema com uma marca.

se for chipset da ricoh e muito boa.

modprobe raw1394
modprobe dv1394
chmod 777 /dev/raw1394

e recomendo instalar o kino pra ver se aparece o vídeo no kino. o vídeo
tem que vir em DV.

se estiver vindo HDV tem usar o dvgrab e uns valores pra pegar o hdv.

http://wiki.pilarcultural.org/DVGrab_(captura_de_HDV)
<http://wiki.pilarcultural.org/DVGrab_%28captura_de_HDV%29>

agora tirando isso...se não adiantar como tu disse que esta usando
unstable...recomendo ver no kernel se esta vindo um modulo firewire
beta/experimental. ei se tive este recomendo compilar com um mais
stable. tive este problema uma vez com fedora com kernel com firewire
diferente.

>
> Está camera eu utilizo acoplada a um microscópio. Alguem tem alguma
> sugestão para fazê-la funcionar no linux?
>
> Valeu
> Inte
> Ronaldo
>


--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4E98BE34.3060800@gmail.com" target="_blank">http://lists.debian.org/4E98BE34.3060800@gmail.com




Reply to: