[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[resoolvido] bootmgr is missing - Somente debian instalado



Muito0 obrigado à ajuda de todos, 
mas o erro acho que estava na correção dos blocos.
Consegui fazer a correção em partes separadas, para que não perdesse os meus dados.
Logo após isso, com o live, montando as partições e com chroot. consegui instalar o grub.

Atento que o grub.cfg (funcionando) ainda continua com o modulo set root = (hd0,msdos1). Muito estranho, porém funcionando.

Abraço a todos e desculpem-me pelos longos textos... mas é que me falta tempo para escrevê-los em menor tamanho. ehehe

----
Arnaldo D'Amaral Pereira Granja Russo
Lab. de Estudos dos Oceanos e Clima
Instituto de Oceanografia
Universidade Federal do Rio Grande
e-mail arnaldorusso [at] gmail [dot] com
tel   (53) 3233-6855



Em 13 de setembro de 2011 20:16, Julio <julio.span@gmail.com> escreveu:
Tenta verificar do disco , as vezes quando está com erro o sistema operacional não inicializa
Arnaldo Russo escreveu:
Muito obrigado pela atenção Ramão.
Infelizmente os métodos ali apresentados, não foram eficientes no momento.
Vou testar em breve o disco de inicialização, mas durante a própria instalação já tive erros ao instalar o grub ou o lilo. Nenhum dos dois o dvd do debian instalou.
Assim, finalizei a instalação e com chroot, instalei via aptitude o grub-pc, onde já me foi configurado o grub certinho.
Estava funcionando tranquilo, até que rolou essa queda de luz.
Ainda não entendi o que pode ter acontecido, mas enfim. Hoje não estou em contato com essa máquina e não conseguirei rebootar por ssh.
obrigado pela ajuda de todos
Abraço,
Arnaldo.
----
*Arnaldo D'Amaral Pereira Granja Russo*
Lab. de Estudos dos Oceanos e Clima
Instituto de Oceanografia
Universidade Federal do Rio Grande
e-mail arnaldorusso [at] gmail [dot] com
tel   (53) 3233-6855



Em 13 de setembro de 2011 19:03, ramao martins <ramao.martins@gmail.com <mailto:ramao.martins@gmail.com>> escreveu:


   Arnaldo, ontem lhe postei umas idéias, mas estou ainda vendo que
   você não resolveu o assunto ainda. As minhas idéias não lhe foram
   úteis? O "Super_Grub2_Disk.iso" é um live_cd. È muito útil para
   recuperar o Grub2. Há outra idéias que gostaria de lhe apresentar,
   caso você não a tenha usado ainda: Há no primeiro disco de
   instalação do debian a opção de recuperar o sistema. Você já
   considerou a hipótese de usá-la? Conteste-me!
   ramao.martins@gmail.com <mailto:ramao.martins@gmail.com>


   Em 13 de setembro de 2011 19:12, Arnaldo Russo
   <arnaldorusso@gmail.com <mailto:arnaldorusso@gmail.com>> escreveu:


       Pode deixar!
       estou no ssh hoje.
       Assim que for para resolver sobre isso, vou postando as coisas
       aqui.

       Obrigado.
       ----
       *Arnaldo D'Amaral Pereira Granja Russo*
       Lab. de Estudos dos Oceanos e Clima
       Instituto de Oceanografia
       Universidade Federal do Rio Grande
       e-mail arnaldorusso [at] gmail [dot] com
       tel   (53) 3233-6855 <tel:%2853%29%203233-6855>




       Em 13 de setembro de 2011 15:33, Rodolfo <rof20004@gmail.com
       <mailto:rof20004@gmail.com>> escreveu:


           boa, se der certo nos avise, para protocolarmos a
           informação :D

           Em 13 de setembro de 2011 10:19, Luiz Marins
           <luizmarins.10@gmail.com <mailto:luizmarins.10@gmail.com>>

           escreveu:

               Bom, seja lá o que for, tenta essa dica aqui, vê se vai:
               http://linuxmeu.wordpress.com/recuperando-mbr/


               On 12 set, 11:40, Arnaldo Russo
               <arnaldoru...@gmail.com
               <mailto:arnaldoru...@gmail.com>> wrote:
               > Bom dia!
               > Estou quebrando a cabeça há alguns dias, com o
               problema seguinte:
               > Após uma queda de luz, ao religar a máquina, uma
               mensagem:
               > BOOTMGR is missing. ctrl - alt - del to restart
               >
               > Estou entrando no meu sistema, através de um disco
               de boot, e inicializando
               > pelo primeiro disco. Apartir daí, ele entra no meu
               GRUB e consigo entrar no
               > Debian.
               >
               > O mais estranho é que o computador é novo, e a
               primeira e única instalação
               > foi o Debain 3.0.0-1-amd64 x86_64 GNU/Linux
               >
               > Código:
               > fdisk -l
               > /dev/sda1   *        2048    97656831    48827392                  83  Linux
               > /dev/sda2        97656832   114040831     8192000                  82  Linux swap / Solaris
               > /dev/sda3       114040832   134520831    10240000                  83  Linux
               > /dev/sda4       134520832  3907028991  1886254080                  83  Linux
               >
               > Como não entendo nada do grub, pois há bastante
               tempo, quando corrigi
               > problemas de boot, era através do stage1, dentro do
               próprio grub, hoje isso
               > não funciona mais (pelo que me parece).
               >
               > Já tentei reinstalar o grub e o erro continua
               aparecendo.
               >  Código:
               > grub-install /dev/sda
               >
               > Obs... Eu não tenho um arquivo menu.lst no meu
               sistema (o que sempre tive
               > nos meus outros debian) e também não tem o
               "grub.conf", somente o "grub.cfg"
               >
               > Para maiores informações, dentro desse arquivo
               existem as linhas:
               >
               > insmod part_msdos
               > insmod ext2
               > set root='(hd0,msdos1)'
               > search --no-floppy --fs-uuid --set=root
               cbe409d1-8152-40b6-8f1a-f14c9ba0c84c
               > if loadfont /usr/share/grub/unicode.pf2 ; then
               >   set gfxmode=640x480
               >   load_video
               >   insmod gfxterm
               >   insmod part_msdos
               >   insmod ext2
               >   set root='(hd0,msdos1)'
               >   search --no-floppy --fs-uuid --set=root
               > cbe409d1-8152-40b6-8f1a-f14c9ba0c84c
               >   set locale_dir=($root)/boot/grub/locale
               >   set lang=pt_BR
               >   insmod gettext
               > fi
               > terminal_output gfxterm
               > set timeout=5
               > ### END /etc/grub.d/00_header ###
               >
               > ### BEGIN /etc/grub.d/05_debian_theme ###
               > insmod part_msdos
               > insmod ext2
               > set root='(hd0,msdos1)'
               > search --no-floppy --fs-uuid --set=root
               cbe409d1-8152-40b6-8f1a-f14c9ba0c84c
               > insmod png
               > if background_image
               /usr/share/images/desktop-base/spacefun-grub.png; then
               >   set color_normal=light-gray/black
               >   set color_highlight=white/black
               > else
               >   set menu_color_normal=cyan/blue
               >   set menu_color_highlight=white/blue
               > fi
               >
               > O que faz um módulo "msdos" dentro do meu GNU/Linux???
               > O estranho disso tudo é que as buscas para
               solucionar esse problema, são de
               > usuários dual-boot. O que não é o meu caso. Nunca
               nem cheguei perto da
               > máquina, com o janelas.
               >
               > Se alguém puder dar uma ajuda de como resolver isso,
               pelo próprio linux,
               > será uma boa!
               > Obrigado.
               >
               > ----
               > *Arnaldo D'Amaral Pereira Granja Russo*
               > Lab. de Estudos dos Oceanos e Clima
               > Instituto de Oceanografia
               > Universidade Federal do Rio Grande
               > e-mail arnaldorusso [at] gmail [dot] com
               > tel   (53) 3233-6855 <tel:%2853%29%203233-6855>



               --
               To UNSUBSCRIBE, email to
               debian-user-portuguese-REQUEST@lists.debian.org
               <mailto:debian-user-portuguese-REQUEST@lists.debian.org>

               with a subject of "unsubscribe". Trouble? Contact
               listmaster@lists.debian.org
               <mailto:listmaster@lists.debian.org>

               Archive:
               df66258c-004b-497d-b826-008f063bdfdc@t29g2000vby.googlegroups.com" target="_blank">http://lists.debian.org/df66258c-004b-497d-b826-008f063bdfdc@t29g2000vby.googlegroups.com







--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 4E6FE43F.6090804@gmail.com" target="_blank">http://lists.debian.org/4E6FE43F.6090804@gmail.com



Reply to: