[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aptitude



aptitude é encrencado mesmo. Veja se ao usar o apt-get para de dar esses problemas.

Eden Caldas
Consultor de TI
eden@linuxfacil.srv.br
(81) 9653 7220
LINUX FÁCIL – Consultoria e Serviços em TI


Em 7 de fevereiro de 2011 19:43, linuser <linuser@terra.com.br> escreveu:
Caros,

Uso o aptitude para instalação/desinstalação de pacotes. Mas agora estou num beco sem saida. A situação é essa:

Uso o Squeeze. Precisava ter instalado o kdevelop 3.5, que é da versão Lenny (a versão 4, que é padrão no Squeeze, não serve). O que eu fiz? baixei os pacotes kdevelop e kdevelop-data e os instalei com dpkg -i etc. Claro que há várias dependências não resolvidas, mas o fato é que o kdevelop assim instalado funciona suficientemente. E é o que eu queria.

Mas o aptitude simplesmente "encrencou" com esse pacote. Ele sugere remover kdevelop. Mas se eu pedir para ele manter na versão atual ("=" Hold a package in its current version to prevent upgrades) sou contemplado com a mensagem "No more solutions". O pacote kdevelop aparece com a cor vermelha sob a rubrica "Packages with unsatisfied dependencies". Surpreendentemente, o pacote kdevelop-data, também da versão Lenny, aparece apenas como "Packages being help back", e não causa maiores problemas.

O fato é que, com isso, não consigo instalar absolutamente nada. Ao comandar a instalação de qualquer pacote (comando "g"), recebo um triste e desestimulante "No solution to these dependency problem exists!"

Até um apt-get upgrade causa problemas. Vejam abaixo.
*****
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 kdevelop : Depends: libapr1 but it is not installed
           Depends: libaprutil1 but it is not installed
           Depends: libcvsservice0 (>= 4:3.5.9-1) but it is not installable
           Depends: libsvn1 (>= 1.4) but it is not installed
           Depends: kdebase-bin but it is not installed
           Recommends: kdevelop-doc but it is not installable
           Recommends: autoconf but it is not installed
           Recommends: automaken
E: Unmet dependencies. Try using -f.
*****

Em suma, há algum meio de manter o pacote instalado sem causar esse rebuliço todo? Ou há um meio de "esconder" este pacote do aptitude?

Saudações.
G.Paulo.


--
To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20110207234319.372ac14d@appia" target="_blank">http://lists.debian.org/20110207234319.372ac14d@appia



Reply to: