[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Som no VMWare Player



> Acredito que houve uma evolução em relação ao problema... acho que o
> dispositivo de som  está sendo utilizado pela máquina real (Linux) e não
> pode ser "compartilhado" sua utilização com a máquina virtual... existe
> solução para isso?

Ótimo, parece que estamos realmente na direção certa. Algumas dicas para
seguir adiante. Para testar se o dispositivo de som está disponível, você não
precisa tentar abrir o vmware. Basta um `cat nomedoarquivo > /dev/dsp` para
você ouvir ruídos no som; se o arquivo for um wav, os ruídos se organizarão
em forma de música.

É possível, como você supôs, que tenha algum outro programa usando o /dev/dsp.
Acho improvável, porque você acabou de criar o dispositivo e nenhum outro
programa usava ele. Pode ser também problema de permissões; veja se você
consegue enviar algo para o dsp como root.

Se não conseguir, deve realmente ser outro programa. Nesse caso, você vai ter
que caçar um pouco com lsof ou fuser (que não sei usar direito). A hipótese
mais comum é um sistema de som, como o arts (do kde) ou o esd (do gnome).

Mais um detalhe: hoje é possível tocar sons simultaneamente com o alsa, não
sendo mais necessária a intermediação de um arts ou esd. Se não me engano,
isto já vem inclusive configurado corretamente no etch.

boa sorte,

Tiago.

-----------------------------------------------------------------------------------------------------------------------------------------

Tiago, enfim consegui!! suas dicas foram valiosas... após inúmeros testes pude perceber que somente após carregar completamente o windows na VM e maximizar a janela do VMPlayer consigo acionar o dispositivo de som.. enfim, está tudo ok! valeu mesmo!

_________________________________________________________________
Descubra como mandar Torpedos do Messenger para o celular! http://mobile.msn.com/



Reply to: