[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: alias eth0 eth1 eth2



Ópa, valeu Marcos.

Vou dar uma olhada! ;-)

2006/12/1, Marcos Lazarini <mvlaza@gmail.com>:
2006/12/1, Denis <denismpa@gmail.com>:
> Galera, houve um negócio muito estranho no meu Debian e eu não sei como resolvo:
>
> Seguinte, eu tenho 3 placas de rede instaladas na máquina
>
> uma linksys, uma yukon e uma realtek.
>
>
> as placas eram na sequencia
>
> linksys eth0
>
> realtek eth1
>
> yukon eth2
>
>
> minha máquina rebootou numa queda de energia, daí corromperam alguns
> arquivos tipo awk...
>
> passei fsck, reinstalei o mawk e o bash
>
> mas as placas agora estão trocadas,
>
> tipo, a eth0 não é mais a eth0 a eth1 nção é mais a eth1, e a eth2 não
> é mais a eth2.
>
> Li em alguns lugares que encontraria dentro de /etc/modules.conf os
> alias para as placas, mas lá dentro não tem alias para nenhuma delas..
>
> li em algum outro lugar também que eu poderia editar o
> /etc/modutils/aliases e colocar da maneira que quero que elas fiquem:
>
> alias eth0 linksys(não lembro qual é o módulo)
> alias eth1 8139too
> alias eth2 sk98lin

Isso nao funciono no debian, só redhat

> fiz isso (exceto com a eth0) e rodei o update-modules
>
> Os alias foram copiados para o /etc/modules.conf e reiniciei a máquina
> mas não funcionou..
>
> Como eu posso fazer para apontar qual vai ser a eth0, a eth1 e a eth2 ????

Ou vc carrega os módulos numa mesma sequencia sempre (coloca eles no
/etc/modules p/ tentar) ou usa o histórico da lista p/ te ajudar:
http://lists.debian.org/debian-user-portuguese/2006/07/msg00832.html

--
Marcos




Reply to: