[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ProFTP dandu mancada!



David Fante wrote:

Marcos V Lazarini escreveu:

David Fante wrote:

E ai pessoal...susu?
Porra jah li pra kct e naum consigo resolver meu prob.
Tenho um Debian Sarge instalado SUPER ATUALIZADO e tals...instalei o Proftp e configurei e tals...na rede internet ele funfa legal...quandu tento acessar pela net ele naum lista o diretorio....ele conecta...mais naum lista. Fica parado ateh aparecer a msg:
/230 User david logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful
425 Unable to build data connection: Connection timed out

/Pô q negocio mais foda...tipow...ai atualizei o Debian pra ver c funfava...e NADA...removi o Proftpd e apaguei o arquivo de conf, depois instalei novamente e NADA, desativei o firewall e o squid e NADA....ativei os modulos:
# modprobe ip_conntrack_ftp
# modprobe ip_nat_ftp
E NADA!!!!!
Tentei usar outra maquina cliente para acessar...usei RUINDOWS com o ftpcommander em modo passivo...e NADA!!!

Naum sei mais o que fazer...alguem pod me dar uma ajuda?
Tipow...to quaze voltandu pro wu-ftp!
/
Ah...só pra constar...eu dei o seguinte comando para verificar algum possivel erro:
tail -f /var/log/messages
...e NADA/

Valew !
David Fante



Kara, vamux falar na sua linguajem, talveix vc intenda melhor:

Essa linha diz tudo:
> 425 Unable to build data connection: Connection timed out
Tanto no modo passivo como no normal, uma outra conexão é estabelecida (o que muda é só quem é que toma a iniciativa). E ele não está conseguindo fazer essa segunda conexão. Não acho que o problema seja o proftp e sim é algo da sua rede (FW local, FW remoto, FW no caminho, rota, masquerade, etc).
De uma verificada ai ou manda mais detalhes.

Certo amigu, se precizar de maix alguma coiza, pá e tal, eh soh mandá pra rapaziada aqui que vão pipoca reisposta!
Valeu ai!

:-)

Ok.
Vamos falar normal aqui, assim você não fica bravo nem incomodado. ;)

É o seguinte, eu fiz toda as verificações, o mais estranho nesse caso é que antes eu tinha um CL 7 com o ProFTP e estava funcionando corretamente, quando decidi mudar para o Debian é que começou a apresentar esse problema. Isso mostra que a minha estrutura está OK o problema é o ProFTP no DEBIAN, ref a configuração eu deixei a padrão para não precisar passando via e-mail aos amigos que se interessem em me ajudar. Eu configurei um firewall, mais eu já desliguei o firewall para testar, desliguei também o SQUID e não funcionou, na rede interna tudo funciona.

O amigo me pediu mais informações, que tipo de informações eu poderia lhe passar para que você possa me ajudar?

Bom, uma coisa que eu tentaria é: já que no debian é facil, tentar instalar um outro servidor FTP e ver se acontece o mesmo.

Detalhes pra entender direito o problema são:
* quem tenta conectar em quem (IP + configurações de rede)
* eles estão na mesma sub-rede? O que tem entre eles?
* talvez o arquivo de configuração do proftp, apesar de eu nunca ter usado ele

--
Marcos



Reply to: