[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Ajuda na instalacao driver nvidia



Pessoal,

Preciso de ajuda na instalacao do driver da nvidia.

Eu trabalho num AMD K7, 256MB RAM, placa de video Riva TNT2 M64 (32 MB).

Meu kernel: 2.4.18-bf2.4

# ls /usr/src

kernel-headers-2.4.18-bf2.4
kernel-image-2.4.18_blinux.1.0_i386.deb
kernel-source-2.4.18
kernel-source-2.4.18.tar.bz2
nvidia-glx-1.0.2880
NVIDIA-Linux-x86-1.0-5336-pkg1.run

Ora, baixei o driver NVIDIA-Linux-x86-1.0-5336-pkg1.run.

# sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

Ao executar o driver, apos aceitar o contrato, o primeiro aviso que
tenho diz o seguinte:

"No precompiled kernel inteface was found to match your kernel, would
you like the installer to attempt to download a kernel interface for
your kernel from th nvidia ftp site?"

Eu opto por nao, ja que se dizer sim ele nao baixa nada e da' no mesmo.

O driver eh instalado, vejam que o problema nao parece estar ai'.

Configuro o arquivo /etc/X11/XFree86confing-4, conforme o "NVIDIA
Accelerated Linux Driver Set README & Installation Guide, Last Updated:
$Date: 2004/01/07 / Most Recent Driver: 1.0-5336", de 66 paginas em
ingles que baixei e fiz questao de imprimir e ler. Ou seja:

"If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

        Driver "nv"
    (or Driver "vesa")

with 

        Driver "nvidia"  

In the Module section, make sure you have:

        Load   "glx"

You should also remove the following lines:
      
        Load  "dri"
        Load  "GLcore"

if they exist.

 Era exatamente o meu caso, e segui essas instrucoes a risca.

O que ocorre eh o seguinte: ao entrar o X (KDM) a tela fica preta com um
cursor vermelho meio que piscando no canto superior esquerdo. Tudo
travado literalmente. Nao podendo nem ir para o modo texto pelo
Ctrl+Alt+1. Tenho que resetar a máquina e entrar pelo "kernel Old", onde
vou diretamente para o console e posso refazer as alteracoes.

Eis o que aparece pertinente ao driver da nvidia, no arquivo
/var/log/XFree86.0.log:

(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found

(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
	compiled for 4.1.0.1, module version = 0.1.0
	ABI class: XFree86 Video Driver, version 0.4
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xE4000000
(--) NVIDIA(0): MMIO registers at 0xE2000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found


Muito obrigado por qualquer ajuda,



-- 
[ ]'s

Tyler




Reply to: