[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Making dead-keys from us_intl layout work with all characters? (fwd)

	Dear readers,

	I sent the message below to debian-x, but I received no

	I would like to know if other people have solutions for the
	problem of making dead-keys work with all caracters and not
	only with letters that can receive accents (see details

	Thanks for any help, Rogério.

P.S.: Please CC'me on replies, as I'm not subscribed to debian-user or

----- Forwarded message from Rogério Brito <rbrito@ime.usp.br> -----

From: Rogério Brito <rbrito@ime.usp.br>
To: debian-x@lists.debian.org
Subject: Making dead-keys from us_intl layout work with all characters?
Date: Tue, 27 May 2003 15:55:39 -0300
User-Agent: Mutt/1.5.4i

	Hi there.

	I recently switched my keyboard layout from us to us_intl, as
	I need accents (previously, I used accents on Emacs only, but
	that was too limiting).

	The problem that I see is that whenever I press a dead-key
	(like tilde), the only keys that generate a symbol after that
	are the letters that should be accented.

	This is more limiting than what I would expect, since the
	combination ~/ is quite common for shells, for instance (but
	not only this combination).

	Emacs' own iso-accents-mode does what I would like to achieve
	(that is, generates a double char sequence after I type 't),
	instead of eating both characters. :-(

	So, is there any way to achieve what I want? I already looked
	at /usr/lib/X11/xkb/symbols/us_intl with the intention of
	modifying it, but the file left me the impression that the X
	server can not generate two characters after one keypress. Is
	that correct?

	What is the appropriate way to change the behaviour to be what
	I want?

	Thanks in advance, Roger...

P.S.: Please let me know if I'm asking the wrong place; also please CC
me on replies.
  Rogério Brito - rbrito@ime.usp.br - http://www.ime.usp.br/~rbrito

----- End forwarded message -----

  Rogério Brito - rbrito@ime.usp.br - http://www.ime.usp.br/~rbrito

Reply to: