[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problema com libdb2



On Thu, Aug 29, 2002 at 08:35:47PM -0300, Luciano wrote:
> Oi pessoal.
> 
> Instalei o tomcat4 (facil a instalaçao, mais facil seria se tivesse um
> pacote com o j2sdk pronto :) e o pacote libapache-mod_jk. Ele configurou o
> apache automatico, mas quando tento rodar o apache:
> 
> -- --
> Starting web server: apacheSyntax error on line 237 of
> /etc/apache/httpd.conf:
> Cannot load /usr/lib/apache/1.3/mod_jk.so into server: libdb.so.2: cannot
> open shared object file: No such file or directory
> failed

Você não teria por acaso pego o Apache, alguma de suas dependências ou
a própria libc6 do unstable, teria ?

Aconteceram alguns problemas com pacotes que dependiam de suporte a
libdb{1,2} há alguns dias/semanas atrás no unstable, pois o suporte a
db1 (ou db2, não me recordo) foi removido da libc6 pelo seu mantenedor.
Isso já vinha sendo feito há tempos pelo desenvolvedor original, mas o
Debian mantinha o código antigo para maior compatibilidade.

Se esse foi o seu caso, tente uma versão nova do Apache da unstable, que
já corrige issoi, ou instale o pacote libd1-compat, criado especificamente
para quem precisa manter aplicativos que requerem suporte a versões
antigas da libdb. Esse pacote é novo e só existe no unstable.

Da descrição do pacote libdb1-compat :

"This library exists for compatibility with applications built against
glibc 2.0 or 2.1. There is intentionally no corresponding development
package. Do not link new applications against this library!"


-- 
++----------------------------------------------------------------------++
||  Andre Luis Lopes                   andrelop@ig.com.br               ||
||  Debian-BR Project                  http://debian-br.cipsga.org.br   ||
||  Public GPG KeyID                   9D1B82F6                         ||
||  Keyserver                          wwwkeys.eu.pgp.net               ||

Attachment: pgph7mLOGPOg9.pgp
Description: PGP signature


Reply to: