[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Decepção com o woody



On Mon, Mar 26, 2001 at 09:42:14PM -0300, Maniak-B wrote:
> Pois é. Temos que correr riscos para ter pacotes recentes em nossas
> maquinas. No entanto, um Debian developer deveria ao menos testar esse
> pacote antes de soltá-lo. Tipo, é meio básico.
> 
> Acho que uma preocupaçãozinha do tipo, testar primeiro não é muito.
> 
> []'s
> Pablo

	Olha, não é simples assim, de vez em quando uma biblioteca básica
(como a libc) tem uma mudança na API, ou por algum motivo não retém 
compatibilidade binária com aplicações que se ligam a uma versão anterior,
ou alguma coisa assim. Quando isso acontece todos os aplicativos que dependem
daquela lib devem ser religados com ela, por mais que o developer desta
lib teste ele pode acabar quebrando outro dos 5000+ pacotes, essa é a 
natureza da coisa, a interação entre os pacotes, e não o pacote em si.

	Ninguém precisa se arriscar a nada para ter pacotes atualizados
no debian, basta pegar os pacotes que você quiser do unstable e
gerá-los para o stable. Em geral é assim que se faz: (Gleydson, acho que
isso podia entrar no foca intermediário, se é que já não tem)

	inclua um deb-src do unstable em /etc/apt/sources.list

	apt-get update

	apt-get source pacotedowoody
	cd pacotedowoody-X.Y.Z
	dpkg-buildpackage -us -uc
	cd ..
	dpkg -i pacotedowody_blablabla.deb

	preste atenção nos Build-Depends dos pacotes que você vai
refazer para ter certeza que tem todos os pré-requisitos.
-- 
Eduardo M. Maçan                                macan (at) colband.com.br
"The buttons I press don't even exist"          macan (at) debian.org

Attachment: pgpRoLqf7AL8a.pgp
Description: PGP signature


Reply to: