[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Munin



Am 23.01.2011 um 22:38 schrieb Sven Hartge:

> Felix Fritzsche <debian@felix-seine.de> wrote:
> 
>> ich komme hier irgendwie nicht weiter und habe mittlerweile einen Knoten im Hirn.
>> Ich habe einige Fehlermeldungen im munin-node.log:
> 
>> 2011/01/23-22:05:11 [13799] Error output from exim_mailqueue:
>> 2011/01/23-22:05:11 [13799]     exim: permission denied
>> 2011/01/23-22:05:11 [13799]     Error closing pipe: 
>> 2011/01/23-22:05:11 [13799] Error output from exim_mailstats:
>> 2011/01/23-22:05:11 [13799]     Logfile '/var/log/exim4/mainlog' is not readable
>> 2011/01/23-22:05:11 [13799] Service 'exim_mailstats' exited with status 13/0.
>> 2011/01/23-22:05:11 [13799] Error output from exim_mailstats:
>> 2011/01/23-22:05:11 [13799]     Logfile '/var/log/exim4/mainlog' is not readable
>> 2011/01/23-22:05:11 [13799] Service 'exim_mailstats' exited with status 13/0.
>> 2011/01/23-22:05:11 [13799] Error output from hddtemp_smartctl:
>> 2011/01/23-22:05:11 [13799]     [ERROR] Command /usr/sbin/smartctl -A /dev/sda on drive sda failed: 512.  The plugin needs to have read permission on all monitored devices.
> 
>> Wie ich das bis jetzt verstanden habe muss in
>> /etc/munin/plugin-conf.d/munin-node angegeben sein mit welchem user
>> der Befehl ausgeführt wird.
> 
> Korrekt.
> 
>> Dies habe ich auch eingerichtet, sieht folgendermaßen aus:
> 
>> [exim_mailqueue]
>> user root
>> group adm, (Debian-exim)
> 
>> [exim_mailstats]
>> user Debian-exim
>> group adm, (Debian-exim)
>> env.logdir /var/log/exim4/
>> env.logname mainlog
> 
>> [hddtemp_smartctl]
>> user root
>> group disk
>> env.drives sda
>> env.type_sda ata
>> #env.smartctl /usr/sbin/smartctl
>> #env.smartpath /usr/sbin/smartctl
> 
>> [smart_*] 
>> user root 
>> group disk 
>> env.smartpath /usr/sbin/smartctl
> 
>> [smart_sda]
>> user root
>> env.smartargs -d ata -a
> 
>> Aber es werden die Einträge irgendwie nicht angenommen.
> 
> Sieht aber gut aus. Du hast munin-node neu gestartet?
> 
> S°
> 
> -- 
> Sig lost. Core dumped.
> 

Gefühlte 10 Mal, klappt aber nicht. Irgendwie werden die user angaben ignoriert.
Wenn ich es unter dem user munin ausführe klappen die Dinge natürlich nicht, aber somit kann ich die Fehlermeldung verstehen.
Es liegt definitiv am 'user root' der wird definitiv nicht genommen. Denn wenn ich die Befehle manuell als root ausführe geht es!

> 
> -- 
> Haeufig gestellte Fragen und Antworten (FAQ): 
> http://www.de.debian.org/debian-user-german-FAQ/
> 
> Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
> mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
> Archive: 07iks2gcp8v8@mids.svenhartge.de">http://lists.debian.org/07iks2gcp8v8@mids.svenhartge.de
> 
> 


Reply to: