[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Nach Paketupdate dauert Bootvorgang sehr lang



Michael Preißler wrote:
> ich habe nach dem Update folgender Pakete:
[...]
> libnss-ldap 251-5.1 -> 251-5.2 
Ich glaube das ist der Übeltäter:(
Seit letzter Woche habe ich auch Probleme/ Timeouts während dem booten
(komischer weise an einem Rechner ganz massiv und an einem anderen gar
nicht, obwohl beide ziemlich gleich konfiguriert sind). Beim starten hat
udev scheinbar Probleme mit der Auflösung von Gruppennamen (einige Gruppen
aus permissions.rules existieren in meiner groups nicht) und die von dir
genannten '/tmp/.X11-unix' und '/tmp/.ICE-unix' gab es Wartezeiten beim
'chown 0:0 ...' (?!)

Soweit ich herausgefunden habe hätte libnss-ldap 251-5.2 gar nicht nach
testing rutschen dürfen, da sie initscripts > 2.86.ds1-20 (welches in etch
bereits frozen ist) voraussetzt.

Als Workaround habe ich folgendes:
Das mitgelieferte init-script aus den runlevels entfernt, da es ein tmpfs
unter /lib/init/rw voraussetzt.
Das Verzeichnis /lib/init/rw erstellt
In einem eigenen init-script habe ich beim start ein
'rm /lib/init/rw/libnss-ldap.bind_policy_soft' eingefügt und ein
'touch /lib/init/rw/libnss-ldap.bind_policy_soft' beim herunterfahren.
Letztendlich versucht das init-script aus dem libnss-ldap-Paket auch nichts
anderes, nur das es leider ohne die o.g. initscripts nicht funktioniert.

Damit läuft der eine Rechner Problemlos hoch, ein anderer hat noch beim
booten noch timeouts beim starten von udev (allerdings wesentlich kürzere
als direkt nach dem Update).

Vielleicht hilft es ja.
Gruß, Michel
-- 



Reply to: