[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ATI X700



On 18.06.06 19:47:20, Klaus Becker wrote:
> Le Dimanche 18 Juin 2006 12:45, Daniel Leidert a écrit :
> > Am Sonntag, den 18.06.2006, 12:30 +0200 schrieb Klaus Becker:>
> > Du kannst nur dein Glück mit den Sid- oder Etch-Paketen des
> > ATI-Installers versuchen, die für X.org 6.9/7.0 gebaut wurden. Es gab
> > auch mal einen Backport der fglrx-Treiberpakete, aber der scheint tot.
> 
> mit den Sid-Paketen hat's tatsächlich geklappt:
> 
> fglrxinfo
> OpenGL vendor string: ATI Technologies Inc.
> OpenGL renderer string: RADEON X700 PRO Generic

Na denn ist ja gut.

> Der Bildschirm ist stark nach links verschoben, und auch wenn ich ihn per 
> Monitor-Einstellungen so weit wie möglich nach rechts verschiebe, bleibt 
> rechts ein schwarzer Streifen. Das war auch vorher schon so, aber die 
> Einstellungen des Monitors konnten es noch ausgleichen.

Hast du den Schirm korrekt eingetragen? Hoert sich irgendwie nach
kaputter Modeline an und die resultiert vmtl. auch falschen
Einstellungen bzgl. des Schirms.

> Die Schriften sind winzig. Ich brauche jetzt Schriftgrößen bis zu 32 (!), um 
> die gleiche Anzeige wie vorher unetr KDE zu haben. In aticonfig hab' ich 
> nichts dazu gefunden. Manipulationen in xorg.conf - dpi100 nach oben, 
> Rausschmeissen von "1152x864" - haben nichts geändert.

Liefert dein Bildschirm Informationen ueber seine Groesse? Sind die
korrekt? Wenn nicht, benutze mal den Parameter DisplaySize und gib dort
die Masse deines Schirms in Millimeter an.

> Zu meinem Erstaunen steht jetzt in xorg.conf u. A.
> 
> Section "Device"
>         Identifier  "Standardgrafikkarte"
>         Driver      "vesa"
>         VideoRam    256
> EndSection
> 
> Section "Device"
>         Identifier  "aticonfig-Device[0]"
>         Driver      "fglrx"
> EndSection

Wieso Erstaunen?

> Händisches Eintragen von fglrx hatte nichts gebracht,

Hu? Fehlermeldung?

> erst nach Neuerstellen 
> der Datei durch aticonfig lief die Kiste.

aticonfig kann dir auch eine xorg.conf im aktuellen Verzeichnis
erstellen und du kannst dann "haendisch" nochmal kontrollieren was du
wirklich uebernehmen willst.

> dpkg-reconfigure xserver-xorg 
> bringt jetzt gar nichts mehr, statt dessen muss ich aticonfig benutzen, ist 
> das richtig?

Ja, dpkg-reconfigure prueft ob xorg.conf von dir veraendert wurde. Wenn
ja, dann kannst du zwar noch alles moegliche auswaehlen aber
abgespeichert wird nichts. Ich weiss leider aus dem Kopf nicht wie das
ging, aber eines der Xorg-Pakete sollte eigentlich was dazu in der
README stehen haben. Ich hab nur auf die Schnelle nicht gefunden
welches. Eventuell geht auch einfach ein dexconf -o /etc/X11/xorg.conf

> 3d-Beschleunigung habe ich noch nicht, darauf komme ich später noch zurück, 
> wenn ich's nicht allein schaffe.

Klaro hast du  die schon. Steht doch oben, das der OpenGL Treiber von
ATI benutzt wird, dann ist OpenGL Beschleunigung auch aktiv.

Andreas

-- 
Your business will assume vast proportions.



Reply to: