[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: g++ problem



Am Mittwoch, 19. April 2006 11:57 schrieb Wolfgang Friedl:
> Halim Sahin wrote:
> > Einen Wunderschönen guten Abend Allerseits,
> >
> > Ich wollte in meinem programm (übersetzbar) mit g++4.0 aus
> > testing/unstable,
> > istringstreams verwenden.
>
> Hallo
>
> (Leider keine Loesung, aber eine echte -also bitte nicht fasch
> auffassen - Verstaendnisfrage)
> Ich dachte immer, dass bis gcc-3.4 oder so zum Kompilieren empfohlen
> wird, und: abgesehen von Kernel/Modulen und manchen Programmen, wo
> die Version/Uebereinstimmung essentiell ist:
> warum muesstest du unbedingt gcc-4.0 verwenden?

Wahrscheinlich weil sich beim Sprung auf 4.0 die ABI geändert hat, und 
dann muss man den 4.0 verwenden, wenn die libs gegen die gelinkt werden 
soll auch mit 4.0 gebaut wurden. Bei stable hab ichs jetzt nicht im 
Kopf, aber bei testing ist das der Fall.

-- 
MfG usw.

Werner Mahr
registered Linuxuser: 303822

Attachment: pgp_c1o2Xx4HG.pgp
Description: PGP signature


Reply to: