[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Asus Server mit SATA und SCSI Platten plus grub error



Am Montag 16 Januar 2006 12:15 schrieb Herbert Diem:
> I habe folgende Maschine
>
> Asus Server mit SATA Kontroller on Board  mit 4 SATA Platten
>
> /dev/sda
> /dev/sdb
> /dev/sdc
> /dev/sdd
>
>
> LSI 320 SCSI Controller  mit 2 SCSI Platten als Mirrror
>
> Sehe die Platten als  /dev/sde für grub (hd4)
>
> Nach dem install von Sarge, hängt der grub loader mit der Meldung "GRUB
> Hard Disk Error"
>
> Wenn ich Suse 10 installiere sieht diese die Laufwerke wie folgend:
>
> LSI 320 SCSI Controller  mit 2 SCSI Platten als Mirrror
>
> Sehe die Platten als  /dev/sda für grub (hd4)
>
> Kontroller on Board  mit 4 SATA Platten
>
>
> /dev/sdb
> /dev/sdc
> /dev/sdd
> /dev/sde
>
>
> Was mach ich falsch
Du legst dich mit dem Bios an.
Du bootest nicht von der niedrigsten Bus-id sondern von der gesteckten Karte.
Folglich remappt das Bios deine Platten. Gut Win fällt auf sowas rein.
Aber Linux läst das Bios links liegen und scannt selbst.
Zwei Möglichkeiten:
- Den onboard im Bios deaktivieren und im Kernel als modul reinnehmen.
- Hersteller anrufen, vernünftiges Bios schicken lassen. Nur bei Asus kein ich 
niemand Kompeteten, die könnne ja nicht mal a) ein Board richtig bedrucken b) 
auf den Fehldruck wenigsten das Handbuch richtig drucken.
Asus wahr mal gut. Aber zu der Zeit war auch noch Pentium I aktuell.

Cu
	Markus

>
>
>
> lg
>
> Herbert
>
>
> Hat sich erledigt:
>
> Habe im Bios die Bootsequenz auf externe Karte als 1. Bootdevice gesetzt.
> Sorry



Reply to: