[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fglrx und Kernel 2.6.12: "Error: could not resolve matching ip-library."



Hi Thomas,

> ,----
> | # if there is no ip-lib file then deterimine which symlink to setup
> | if [ ! -e $lib_ip_base ];
> | then
> |  if [ -e ${lib_ip_base}.GCC$cc_version ];
> |  then
> |  # we do have an ip-lib that exactly matches the users compiler
> |  ln -s ${lib_ip_base}.GCC$cc_version ${lib_ip_base}
> `----
> 
> wobei mir der erste Test relativ witzlos erscheint. Würde der true
> ergeben wäre das Script schon im vorherigen Abschnitt ausgestiegen.
> 
> [...]
> 
> ,----
> | # after the loop there should be a file or a symlink or whatever
> | if [ ! -e ${lib_ip_base} ]
> | then
> | echo "ls -l ${lib_ip_base}*" >>$logfile
> | ls -l ${lib_ip_base}* 2>/dev/null >>$logfile
> | echo "Error: could not resolve matching ip-library." | tee -a $logfile
> | exit 1
> `----
> 
> sieht das aus der Ferne so aus als ob das Anlegen des Symlinks nicht
> klappt.

Das war der Fehler. Ich musst ihn manuell anlegen. Dann kam der Fehler
nicht mehr. Dafür habe ich jetzt andere Kompilationsfehler.

Danke für den Hint.

Grüssle, Tobi



Reply to: