[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hiilfe.....apt-get dist-upgrade fehlgeschlagen



m. kaeser schrieb:

Hallo
wollte mal wieder mein Debian (SID) upgraden, doch kurz nachdem alle neuen Pakete runtergeladen waren, und apt mit deren Installation begann brach er wieder ab:

::::::::::::::::::::

Möchten Sie fortfahren? [J/n] j

Preconfiguring packages ...

Richte tar ein (1.13.93-4) ...

(Lese Datenbank ... 126163 Dateien und Verzeichnisse sind derzeit installiert.)

Vorbereiten zum Ersetzen von kdelibs-data 4:3.1.5-1 (durch .../kdelibs-data_4%3a3.2.2-2_all.deb) ...

Entpacke Ersatz für kdelibs-data ...

Ersetze die Dateien im alten Paket koffice-data ...

dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/kdelibs-data_4%3a3.2.2-2_all.deb (--unpack):

versuche »/usr/share/mimelnk/application/vnd.sun.xml.calc.desktop« zu überschreiben, welches auch in Paket openoffice-de-en ist

dpkg-deb: Unterprozess paste getötet mit Signal (Datenübergabe unterbrochelp ... hen (broken pipe))

Vorbereiten zum Ersetzen von util-linux 2.12-6 (durch .../util-linux_2.12-7_i386.deb) ...

Entpacke Ersatz für util-linux ...

Fehler traten auf beim Bearbeiten von:

/var/cache/apt/archives/kdelibs-data_4%3a3.2.2-2_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

mka@eexee:/$

:::::::::::::::::::


Habe darauf versucht KDE alleine zu installieren :
,,,,,,,,,,,,

mka@eexee:/$ sudo apt-get install kde

Paketlisten werden gelesen... Fertig

Abhängigkeitsbaum wird aufgebaut... Fertig

kde ist schon die neueste Version.

Sie möchten wahrscheinlich ,,apt-get -f install" aufrufen, um dies zu korrigieren:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:

kdelibs4: Hängt ab: kdelibs-data (>= 4:3.2.1) aber 4:3.1.5-1 soll installiert werden

E: Nichterfüllte Abhängigkeiten. Versuchen Sie ,,apt-get -f install" ohne jeglich Pakete (oder geben Sie eine Lösung an).

mka@eexee:/$
:::::::::::::::::::::::::::::::::


Dasselbe mit -f

Scheint ein Abhängigkeiten-Fehler der kdelib4 und kdelibs-data vorzuliegen. Die neue Version die apt runtergeladen hat ist zu neu für viele installierte kde pakete ..... diese sind aber wahrscheinlich auch in einer neuen version runtergeladen worden, aber noch nicht installiert ...

hmmmm keine Ahnung wie ich diese lösen kann bzw. wo ich beginnen soll

kann mir jemand helfen?

vielen dank

matthias


da die Datei  /usr/share/mimelnk/application/vnd.sun.xml.calc.desktop
wohl eh nich lebenswichtig für dein System ist.
kanste ja mal nach /var/cache/apt/archives
wechseln und dort mit
dpkg -i --force-all kdelibs-data_4%3a3.2.2-2_all.deb
den kdekrams installieren und dann mit deinem dist-upgrade fortfahren.
und dich fragen obe es WIRKLICH einen ernsthaften Grund gibt sich sid
anzutun.

Gruß
Martin



Reply to: