[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xfree Frequenzprobleme



Hallo Johannes,

Am Son, 2004-03-21 um 15.43 schrieb J. Volkmann:
> ich habe hier eine Nvidia Karte, welche mit dem Treiber direkt von
> Nvidia läuft und betreibe daran einen Sony CPD E200E.
> 
> Bisher hatte ich mit den Frequenzen keinerlei Probleme, in der
> XF86Config-4 stand:
>                 HorizSync       30-60
>                 VertRefresh     50-75
> Doch sobald ich ein Spiel starte (SDL - handelt sich hier um nwn), 
> welches 800x600 Vollbild benutzt, habe ich gigantische 56 Hz...
> 
> Ergo mal bei google gewühlt welche Modelines da so auftauchen... und
> fand folgendes:
> (II) NV(0): Sony|Sony CPD-E200/E200E: Using hsync range of 30.00-85.00
> kHz
> (II) NV(0): Sony|Sony CPD-E200/E200E: Using vrefresh range of
> 48.00-120.00 Hz

das sind kein "Modelines", sondern die horizontale bzw. vertikale
Refreshrate eines Monitors. Und die Werte solltest Du besser in der Doku
zu Deinem Monitor nachschlagen oder bei Sony nachsehen, als Dich auf das
zu verlassen, was jemand im Web schreibt. 

> Habe ich bei mir eingetragen, was jedoch schlicht nichts brachte. In
> 1024 habe ich jetzt 85 Hz (vorher 75), in 800x600 immernoch 56 Hz. Das
> ist mir irgendwie schleierhaft...

Prüf' doch mal nach, ob es in Deiner XF86Config-4 überhaupt Modelines zu
800x600 gibt, müsste dann etwa so aussehen:

# 800x600 @ 75Hz (VESA) hsync: 46.9kHz
ModeLine "800x600" 49.5 800 816 896 1056  600 601 604 625 +hsync +vsync

Eine ebenfalls zulässige Schreibweise sieht so aus:

Section "Modes"
	Mode "800x600"
	 DotClock 49.5
	 HTimings 800 816 896 1056
	 VTimings 600 601 604 625
	 Flags "+HSync" "+VSync"
	EndMode
EndSection



Gruß, Joachim
-- 
Joachim Seelig                     joachim@kruemel.han.de
Froebelweg 13                      +49 5136 893346
31303 Burgdorf / Germany          



Reply to: