[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [RESOLU] Re: webCam Orbicam intégrée à Aspire 7004WSMi [RESOLU]



Bonsoir Thierry,
Sur ce site : https://linux-uvc.berlios.de/
Tu verras que dans la section (supported devices) à l'avant dernière ligne ta webcam est supporté par linux-uvc.
ça ne change rien mais ceci explique cela;-)
A+

thierry gabet a écrit :
Salut tous le monde,

Je reviens sur mon sujet avec de bonnes nouvelles (pour moi), et j'explique donc la résolution du dilemne pour en faire bénéficier ceux qui serait éventuellement interressé :

Je rappel que j'ai un portable ACER Aspire 7004WSMi.
Dans un premier temps, la commande lsusb me renvoie :
       
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 5986:0100
Bus 001 Device 001: ID 0000:0000

Il me faut donc identifier le constructeur 5986 et son matériel 0100 !
Un petit tour sur  http://www.linux-usb.org/usb.ids  , manque de bol ce constructeur n'y est pas listé ; mais au moins je passe le lien à ceux qui ne le connaissait pas :-)

Bon pas grave, on fouille sur le net et là je trouve l'information suivante : l'ID 5986 correspond au constructeur BISON et le idProduct 0x100 correspond à ACER Orbicam basé sur un chipset  Ali, M5607  . Hum, tout ça me paraît cohérent puisque j'ai bien un portable ACER !!

OK, on continue de fouiller et là deux sons de cloches différents : pour certains il faut installer le pilote gspca et pour d'autre le pilote uvcvideo.
Solution 1 :
J'ai tenté d'abord avec gspca en passant par module assisstant : marche pas !! En fait je parviens à charger le module, mais je n'avais pas /dev/video0 de créé ?! j'ai abandonné cette voie, mais Je me rend compte  tardivement que j'aurais pu créé le noeud : #mknod /dev/video0 c 81 0
                                                                                                                                                  #chmod 666 /dev/video0

Solution 2:
Bon, tant pis, j'ai opté pour le second pilote fournis via svn :   

#svn checkout svn://svn.berlios.de/linux-uvc/linux-uvc/trunk
#cd trunk
#make && make install
#modprobe uvcvideo
#lsmod|grep uvcvideo

uvcvideo               46020  0
compat_ioctl32          1792  1 uvcvideo
videodev               21440  1 uvcvideo
v4l1_compat            12356  2 uvcvideo,videodev
v4l2_common            20736  2 uvcvideo,videodev
usbcore               113412  4 uvcvideo,ohci_hcd,ehci_hcd

-> Nickel le module est chargé !! Je test avec camorama ===> m***de !! marche pas ! (message d'erreur "could not connect to video device (/dev/video0), please check connection")
Allez, je test tout de même avec un autre soft ... va pour Skype, après tout c'est pour lui que je galère sur ma webcam ! ==> GENIAL, CA MARCHE !!! et en plus la couleur est impecable, l'image est parfaite !

Voilà, en esperant que cela profitera à d'autre !


 Le 10/11/07, thierry gabet <tgabet@gmail.com > a écrit :
Ce n'est pas une question d'installation du module, car je parviens à l'installer sans problème. Un coups de "lsmod | grep gspca" et hop je le vois correctement chargé, là n'est pas le problème. Le problème est plutôt que l'installation semble incomplète car /dev/video n'est pas créé.

Je vais mettre en suspend ce problème car je viens de repasser en Stable pour tenter une installation propre de gspca dessus.
Mais pour le moment j'ai un problème de "somme de contrôle MD5 incohérente" pour les mise à jours de sécurité, et impossible de récupérer les linux-header via synaptic. Je vous tiens au courant, et je revient au sujet plus tard.
Merci et bon week-end

Le 10/11/07, Claude Bobey < claudebobey@gmail.com> a écrit :
Bonsoir,
Gspca est dans les dépôts officiels :

   apt-cache policyapt-cache policy gspca-modules-2.6.22-2-686
   gspca-modules-2.6.22-2-686:
     Installé : 2.6.22+01.00.18-2
     Candidat : 2.6.22+01.00.18-2
    Table de version :
    *** 2.6.22+01.00.18-2 0
           500 http://ftp.fr.debian.org testing/main Packages
           100 /var/lib/dpkg/status

Donc, un aptitude-install gspca-modules-2.6.22-2-686 (ou le module
adapté à ton noyau) fera l'affaire
Plus d'info sur ce petit tuto :
http://www.coagul.org/article.php3?id_article=574
Bonne install et wengo ou Ekiga (tous les deux libres et vidéo intégrés
depuis longtemps sous Linux) existent à la place de Skype (proprio...)
A++
(PS : Mes plates excuses à Philippe auquel j'ai envoyé un mail par
inadvertance.)

Philippe Merlin a écrit :
> Salut,
> pour moi lsusb est un peu plus bavard, mais je pense que cela n'a pas
> d'importance. Dans mon cas je n'ais pas le module usbcore installé,
> par contre j'ai les modules v4l2_common et v4l1_compat.
> un ls -l /dev/vid* donne:
>  crw-rw---- 1 root video 81, 0 2007-11-09 10:07 /dev/video0
> en espérant que cela t'aidera, as tu regardé le lien que je t'ais donné.
> A+
> Philippe MERLIN
>
>
>
> Le vendredi 9 novembre 2007, thierry gabet a écrit :
>
>> Merci du coups de main,
>>
>> J'avais déjà fait un lsusb simple mais qui ne m'a rien renvoyé
>> d'interressant.
>> Je te colles tout de même ce que j'avais eût :
>>
>> $ lsusb
>>
>> *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
>> Bus 002 Device 002: ID 5986:0100
>> Bus 002 Device 001: ID 0000:0000
>> Bus 001 Device 001: ID 0000:0000
>> *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
>>
>> avec l'option d'affichage détaillé (lsusb -v), c'est encombrant à mettre
>> dans un mail car il y en pour 432 lignes !
>> Mais en fait que peut m'apporter de plus la commande lsusb, si ce
>> n'est que
>> la webcam est bien détectée sur le Bus 002
>>  Device 002 ?
>> Donc pour résumer, ma camera est bien vue (lsusb le confirme) et mes
>> recherches sur le net me laissent penser avec quasi certitude que c'est
>> lbien e driver gspcav1 qu'il me faut. L'installation du driver se
>> fait sans
>> problème, mais pourtant quelque chose coince !
>>
>> Mon noyau actuel 2.6.22.2, et sur le 2.6.23 c'est le même problème.
>>
>> La commande dmesg ne me renvoi rien en rapport avec ma webcam.
>> $ dmesg | grep camera  -> renvoie rien
>> $ dmesg | grep gspca -> renvoie rien
>> $ dmesg | grep usb
>> *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
>>
>> usbcore: registered new interface driver usbfs
>> usbcore: registered new interface driver hub
>> usbcore: registered new device driver usb
>> usb usb1: configuration #1 chosen from 1 choice
>> usb usb2: configuration #1 chosen from 1 choice
>> usb 2-6: new high speed USB device using ehci_hcd and address 2
>> usb 2-6: configuration #1 chosen from 1 choice
>> *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
>>
>>
>> Le 09/11/07, Philippe Merlin <phil-deb1.merlin@laposte.net> a écrit :
>>
>>> Le vendredi 9 novembre 2007, Philippe Merlin a écrit :
>>>
>>> Salut,
>>> Complément  à mon message, quel est le niveau de ton noyau ?
>>> si linux <2.6.11 (de mémoire) ce n'est pas gspcav1.
>>> Autre info si tu regardes les log avec dmesg tu dois avoir a peu près
>>> ceci c'est un copier coller  pour ma webcam.
>>> /usr/src/gspcav1-20070508/gspca_core.c: USB GSPCA camera found.(ZC3XX)
>>> /usr/src/gspcav1-20070508/gspca_core.c: [spca5xx_probe:4098] Camera
>>> type
>>> JPEG
>>> /usr/src/gspcav1-20070508/Vimicro/zc3xx.h: [zc3xx_config:515] Sensor
>>> ID:22 A+
>>> Philippe MERLIN
>>>
>>>
>>>> Le vendredi 9 novembre 2007, thierry gabet a écrit :
>>>>
>>>>> Désolé, premier mail envoyé comme un bourrin n'importe comment ! Je
>>>>> recopie ici
>>>>>
>>>> Salut,
>>>> Je ne connais rien à l'orbicam, je pense cependant qu'un lsusb sera
>>>> plus profitable, regarde ce mode d'emploi pour orbicam sur un forum
>>>> ubuntu : http://forum.ubuntu-fr.org/viewtopic.php?pid=767475
>>>> En espérant t'avoir aider .
>>>> A+
>>>> Philippe MERLIN
>>>>
>
>
>
>
>


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org





Reply to: