[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problème libgnutls12+ problème nvidia-glx lors du dist-upgrade



Bonjour,

J'ai voulu lancé un dist-upgrade avec aptitude, et j'ai eu ceci:

debian:/home/thierry# aptitude dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
  cupsys evolution-data-server kudzu libcamel1.2-6 libcupsys2
  libegroupwise1.2-8 libgnomevfs2-0 libgnutls11 libopenh323-1.15.6
  libsoup2.2-8 nvidia-glx vlc
The following NEW packages will be automatically installed:
  libnewt0.52 libpt-1.10.0
The following packages will be automatically REMOVED:
  libgnutls12 libnewt0.51 libpt-1.8.7
The following NEW packages will be installed:
  libnewt0.52 libpt-1.10.0
The following packages will be REMOVED:
  libgnutls12 libnewt0.51 libpt-1.8.7
The following packages will be upgraded:
  libpt-plugins-oss libpt-plugins-v4l libtasn1-2 python-newt whiptail
The following packages are RECOMMENDED but will NOT be installed:
  libtasn1-2-bin
6 packages upgraded, 2 newly installed, 3 to remove and 0 not upgraded.
Need to get 5358kB of archives. After unpacking 266kB will be used.
The following packages have unmet dependencies:
  libcamel1.2-6: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  libgnomevfs2-0: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  libegroupwise1.2-8: Depends: libgnutls12 (>= 1.2.5) but it is not
installable
  libgnutls11: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  libsoup2.2-8: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  kudzu: Depends: libnewt0.51 but it is not installable
  libopenh323-1.15.6: Depends: libpt-1.8.7 but it is not installable
  evolution-data-server: Depends: libgnutls12 (>= 1.2.5) but it is not
installable
  vlc: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  libcupsys2: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  cupsys: Depends: libgnutls12 (>= 1.2.5) but it is not installable
  nvidia-glx: Depends: nvidia-kernel-1.0.8756 which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
libopenh323-1.15.6

Keep the following packages at their current version:
libgnutls12 [1.2.9-2 (unstable, now)]
libnewt0.51 [0.51.6-31 (now)]
libnewt0.52 [Not Installed]
libtasn1-2 [0.2.17-1 (now)]
nvidia-glx [1.0.8178-3 (now)]
python-newt [0.51.6-31 (now)]
whiptail [0.51.6-31 (now)]

Score is -471

Accept this solution? [Y/n/q/?] q


Je vois qu'il dit que pas mal de paquets seront cassés à cause de
libgnutls12, or ce paquet n'a pas de version candidate à mettre à jour:

debian:/home/thierry# apt-cache policy libgnutls12
libgnutls12:
  Installed: 1.2.9-2
  Candidate: 1.2.9-2
  Version table:
 *** 1.2.9-2 0
        990 ftp://ftp2.fr.debian.org unstable/main Packages
        100 /var/lib/dpkg/status

J'ai donc du mal à comprendre pkoi d'un coup y'aurait ce problème de
dépendances avec tous ces paquets là.

Sinon, j'aimerais ausi qu'ils me mettent à jour nvidia-glx, pour passer
à la version 1.0.8756-2 (j'ai la 1.0.8178-3 d'installer), mais le
problème c'est qu'il dit que ça depend de nvidia-kernel-1.0.8756 qui est
un paquet virtuel et qui n'existe donc pas.

Et c'est bête pq j'ai bien le vrai paquet nvidia-kernel-source d'installer.

Faut attendre qu'ils changent la dépendance de nvidia-glx ?

Merci :-)
A+

Merci :-)
A+



Reply to: